camera capture with libargus when system bootup problem

Hi all,

We want to auto-run a camera programming (libargus based) when system bootup,
and we try to add the camera programming launch command in /etc/init.d/rcSxxx,
but we will get an error with this message when command trigger:

Apr 19 13:35:24 tegra-ubuntu init camera
Apr 19 13:35:31 tegra-ubuntu Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Apr 19 13:35:31 tegra-ubuntu Unable to init server: Could not connect: Connection refused
Apr 19 13:35:31 tegra-ubuntu (snr_camera:2769): Gtk-WARNING **: cannot open display::0

We had tried to export DISPALY=:0 before the camera programming launch command but didn’t work
Does anyone have idea?
Thank you very much.


make sure the argus_daemon is start before your script.

Hi ShaneCCC,

We confirmed the argus_daemon didn’t have problem.

BTW, we used the same command with ssh (ubuntu authority),
we didn’t get any error.


export DSIPLAY=:0
snr_camera argus_capture

Maybe this issue is cause by root authority of xwindow,
but I don’t know how to fix.
Thank you very much.


Could it be the X not start up yet. Could you try add it to much later place.

Hi ShaneCCC,

Thanks for quick reply.
I postpone the launch command with 90s delay but still fail.


Could share the detail what did you do.

Hi WalkerHsiao,

Have you clarified the cause and resolved the problem?