can cuda be used with Tesla M10 ?

I saw this post:

I am running into a similar issue, but it’s about M10. I created a VM with GRID M10-8Q and I wanted to use cuda to accelerate computing when doing deep learning. But, I cannot find a driver for Tesla M10 here:
I was suggested to use the M60 driver instead. But it didn’t seem to work. I tried ubuntu 16.04, cuda 8.0, and nvidia-diag-driver-local-repo-ubuntu1604-384.66_1.0-1_amd64.deb and I got an error when ran CUDA devicequery sample:
CUDA Device Query (Runtime API) version (CUDART static linking)
cudaGetDeviceCount returned 30
-> unknown error

I wonder if I can use cuda in a VM with Tesla M10 and what should I do if it is possible?



That is not the right location to download GRID drivers. I don’t know why it’s still there, it adds nothing but confusion and causes problems.

As linked to in the other post you mention, you need to go here: and register for a GRID evaluation. This will then give you access to the (correct) drivers.

With Maxwell GPUs, you have 2 ways of using CUDA. The first is with an 8Q profile, the second is by using Passthrough. However by using Passthrough, you lose the benefits of the GRID software which gains in features and functionality with each release …

With the new Pascal GPUs (P4, P6, P40 and P100) and GRID 5 (available September 1st), you can use CUDA on all Q profiles

So in answer to your question:

Yes you can, and all you need to do is use the correct drivers and choose either an 8Q vGPU profile or use Passthrough.



Just as addition: As the Tesla M60 is in general a Compute board it is necessary that we provide drivers for Passthrough usage for compute purposes in the "normal" drivers download section.
But the Tesla M10 was especially built for GRID, so there is no real compute purpose and therefore no driver in the download section but in the GRID portal…



Thank you for your reply. I have successfully installed cuda with the right driver. Thank you again!!




facing the same problem with a M10.
Register for the Grid Eval but there are only Driver for the virtualization.

Where do I find the cuda drivers?

Will use the M10 also with pass through



Hi Heiko,

and what is wrong with these drivers? For sure these drivers support CUDA…



Hi Simon,

the problem is, I only find the grid drivers for ESX, XEN, KVM but not the cuda drivers for in my case UBUNTU 16.4 LTS (a *.deb file) and the nv drivers to overwrite the noveau drivers.



So to be more precise. the graphics driver (in the physical world "nv" driver ) for the virtual Ubuntu machine that on which on top the cuda driver are unstalled

It’s now running. Thanks for helping


I think I am having the same problem as Heiko did.
I am running Hyper-V with M10 DDA Pass-Through to an Ubuntu18.04 VM.
The installation of the driver ( from the portal and adding the license worked fine so far (nvidia-smi shows a normal output). Where do I get a compatible CUDA Version for this driver?

EDIT: Using the runfile and only installing the toolkits worked for me, deselect the driver!

wget sh

Containers with cuda also work fine now.