Can not enable Wayland on JP 6.0 GA

A fresh JP 6.0 installation and run nvstart-weston.sh in Terminal.
The Orin restart instantly, after restart, Settings → System → Windowing system still shows X11

weston-simple-egl gets a segmentation fault.

I’ve read Weston (Wayland) — NVIDIA Jetson Linux Developer Guide 1 documentation

Am I missing any step?

In my recent attempt, the AGX orin restarts instantly when I run nvstart-weston.sh
It stuck on restarting. I had to pull the power cable and re-plug it in. The monitor detected the signal but showed nothing, even during the UEFI boot stage.

Here’s the log: minicom.cap.txt (3.7 MB)

Hi @jasl9187

Is the issue still there after skipping oem-config?

I just think this issue shows a similar pattern to my flashing issue.
However, this one isn’t related to oem-config.
I run nvstart-weston.sh on a configured installation

I record a new output on the skip oem-config installation.

What I’ve done:

  • Connect the AGX Orin to pure DP
  • Manual flash the AGX Orin eMMC that skipping oem-config (you taught me on my another post)
  • Run sudo apt update && sudo apt -y dist-upgrade && sudo apt -y autoremove and reboot
  • Open the Terminal app, run nvstart-weston.sh
    • I saw it requires me to type my password
    • After typing the password, it reboots instantly
    • However, it stuck on rebooting (serial console flood CBB errors), so I had to plug out the power supply
  • After reboot, Gnome Settings → About → Windowing system shows X11

the output records the process: minicom.cap.txt (269.4 KB)

Even when I use pure DP, the CBB error is still there. It occurred on shutdown or rebooting.

I reflash to 5.1.3, nvstart-weston.sh still not working

  • The monitor reports no signal
  • Serial console shows it doesn’t reboot, and running normal except display
  • I can get /tmp/weston-startup.log in serial console
jasl@jasl-tegra:~$ cat /tmp/weston-startup.log 
Date: 2024-05-06 CST
[02:22:39.778] weston 6.0.1
               http://wayland.freedesktop.org
               Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=3.0.0
               Build: unknown (not built from git or tarball)
[02:22:39.779] Command line: /usr/bin/weston
[02:22:39.779] OS: Linux, 5.10.192-tegra, #1 SMP PREEMPT Mon Feb 19 20:19:53 PST 2024, aarch64
[02:22:39.780] Using config file '/etc/xdg/weston/weston.ini'
[02:22:39.781] Output repaint window is 8 ms maximum.
[02:22:39.781] Loading module '/usr/lib/aarch64-linux-gnu/weston//drm-backend.so'
[02:22:39.783] initializing drm backend
[02:22:39.783] no drm device found
[02:22:39.783] fatal: failed to create compositor backend
[02:22:39.783] Internal warning: debug scope 'drm-backend' has not been destroyed.

Could you follow these steps instead of script?

I guess " $ sudo modprobe nvidia_drm modeset=1" is missing.

I believe this line causes trouble,
The console shows:

[   72.683332] [drm:nv_drm_exit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00020000] Failed to grab modeset ownership
[   74.763332] [drm:nv_drm_exit [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00020000] Failed to grab modeset ownership

This is on JP 5.1.3

Could you manually set weston up instead of running script from scratch?

Sorry, I just notice I forgot to paste the document.

https://docs.nvidia.com/jetson/archives/r36.3/DeveloperGuide/SD/WindowingSystems/WestonWayland.html?highlight=weston#to-launch-weston-manually

Yes, manual set Weston up works.
It starts with a very basic desktop, not Gnome DE.

I got this error a couple weeks ago trying to install debian 12 and ubuntu 22.04 on a system with an amd r5 7600x and rtx 4070ti super. I never figured out what caused it or fixed it.

So, nvstart-weston.sh does not work on JP 5.1.3. The manual can start with a simple shell.

Can JP Wayland power Gnome DE?

Because of the JP 6.0 bug, I can’t try it. Could you help to test after the bug is fixed?