Can not upgrade to tourchvision 0.7.0 from 0.2.2.post3


It seems like the new version of fastai is not working with Jetson Xavier NX (Aarch64 build).
The only prolem that i can not upgrade tourchvision to 0.7.0 from 0.2.2.post3.

I already tried to update the version by PyTorch for Jetson - version 1.6.0 now available (and download the l4t-pytorch and l4t-ml containers from NGC for JetPack 4.4) but nothing seems to work and i still with tourchvision 0.2.2.post3.

Defaulting to user installation because normal site-packages is not writeable
Collecting fastai
  Using cached fastai-2.0.11-py3-none-any.whl (354 kB)
Requirement already satisfied: fastcore>=1.0.5 in /home/e/.local/lib/python3.6/site-packages (from fastai) (1.0.9)
Requirement already satisfied: requests in /usr/lib/python3/dist-packages (from fastai) (2.18.4)
Requirement already satisfied: fastprogress>=0.2.4 in /home/e/.local/lib/python3.6/site-packages (from fastai) (1.0.0)
ERROR: Could not find a version that satisfies the requirement torchvision>=0.7 (from fastai) (from versions: 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.2.0, 0.2.1, 0.2.2, 0.2.2.post2, 0.2.2.post3)
ERROR: No matching distribution found for torchvision>=0.7 (from fastai)

It looks like it is trying to install torchvision from PyPi repo via pip, as opposed to building the version from source (as is shown in the PyTorch for Jetson thread you linked to).

If you import torchvision from a python3 terminal and print torchvision.__version__, what version does it print?

When you are installing fastai via pip, you could try pip’s --no-dependencies flag so it skips failing on torchvision, which it sounds like you already have installed. You might also want to ask the fastai package maintainers how to install their package in this scenario.


A. 0.2.2.

B. The main problem here by PyTorch for Jetson - version 1.6.0 now available PyTorch v1.6 whl installation file is supposed to come with tourchvision 0.7.0 (the last version) “* PyTorch v1.6 - torchvision v0.7.0” but it is not true. The problem here is tourchvision 0.7.0 is not build for Aarch64 (Jetson Xavier NX) and JETPACK 4.3 at all.

–no-dependencies not helping here because i am getting the error:

~/.local/lib/python3.6/site-packages/fastai/vision/models/ in <module>
     11 # Cell
     12 from ...torch_basics import *
---> 13 from torchvision.models.utils import load_state_dict_from_url
     15 # Cell

ModuleNotFoundError: No module named 'torchvision.models.utils'

Could you confirm to me that Jetson Xavier NX (With PyTorch v1.6 and Jetpack 4.4) could run tourchvision 0.7.0?
I am already a week trying to solve this issue. please upgrade and update the PyTorch v1.6 from PyTorch for Jetson - version 1.6.0 now available

Yes, you can install torchvision 0.7 from source on JetPack 4.4 production release (L4T R32.4.3) according to the instructions in the PyTorch thread.

The PyTorch wheel itself does not come with any torchvision, they are different packages. You would need to build torchvision after you have installed PyTorch wheel.

The l4t-pytorch:r32.4.3-pth1.6-py3 container already has PyTorch 1.6 and torchvision 0.7 installed. If that is still not working with FastAI project, you might need to confirm with FastAI on status of the support.