Cannot compile any example project after installating VS 2019 (or 2017), CUDA 10.2, cudnn

First of all, I decided to ask this question after a search with “VCProjectShim” did not return any result.

On my Windoes 10 notebook with a GT1650, I have just installed Visual Studio 2017, Visual Studio 2019, CUDA 10.2, and cudnn following the instructions given at:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

After the installation of VS2019, I had to copy some files with custom confiurations, as indicated here:

https://devtalk.nvidia.com/default/topic/1049524/cuda-setup-and-installation/cannot-run-samples-on-ms-visual-studi-2019/

However, when I right click on the project “deviceQuery” (in 1_Utilities contained in the Samples_2019’), and select “Build”, VS 2019 opens a “Save as” dialog with this filename:

C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.2\7_CUDALibraries\nvJPEG_encoder\nvJPEG_encoder_vs2019.vcxproj

with type: Save as UTF-8 Project File (*.vcxproj)

After I select the desktop as the folder, I reiceve an error with the following message:

The method or property “VCProjectShim::put_ProjectFile” is deprecated and no longer impemented.

This goes beyond my current competencies and don’t know what to do. Is there anyone who can help me?

PS. I receive the same error with VS 2017. The only difference between VS2017 and VS2019 is that I was not forced to copy the custom configuration files before receiving that error.

None of this should be necessary.

Install windows 10.
Install VS2019
Install CUDA 10.2

You shouldn’t have to manually copy files from one place to the other. If you’ve done so, it means that you’ve done something out of order (for example, install VS after CUDA). The devtalk article you linked refers to someone who is trying this:

“It’s a 2017 project that I am trying to use in 2019.”

Which is not a standard development path, and should not be needed or in any way involved in compiling or running sample codes on VS2019.

I’ve followed the path above (windows install, VS2019 install, CUDA 10.2 install) and it works correctly. You can build sample projects without any extra steps.

I will try to uninstall everything using the add/remove feature on Windows 10 and report back.

Are you aware if the default uninstall methods are enough for reaching a clean state?

PS. If I try and reinstall CUDA 10.2 (without uninstalling) I get an Unhandled exception during the installation procedure.

default uninstall methods are not enough to reach a clean state

It should generally not require a clean state to reinstall things. The unhandled exception does suggest however that things are badly messed up on your machine.

If you want to truly start with a clean state, reinstall windows.

If you want to clean out every bit of NVIDIA software, some general instructions are here:

https://devtalk.nvidia.com/default/topic/1033111/cuda-setup-and-installation/cuda-9-1-cannot-install-due-to-failed-visual-studio-integration/post/5259359/#5259359

The unhandled exception seems related to VS2015, that the installer cannot find. VS2015-related packages are the only ones that result not installed at the end of the installation wizard. However, the error message with “VCProjectShim::put_ProjectFile” stays the same after reinstalling only CUDA 10.2.

However, I followed those instructions on a clean and fresh notebook. So even reinstalling windows would not guarantee success since I would have to use the recovery partition that would put everything as it was.

The fact that I am asked to save a new solution file when I build and that I receive the VCProjectShim::put_ProjectFile error both for VS2017 and VS2019 does not suggest any attempt I could make?

sorry, I don’t have any further suggestions.

This is a community, so maybe someone else will recognize this particular case.

Solved, I need to run Visual Studio 2019 as administrator. If I run it as an administrator, the solution is saved in its original location and the build succeeds without any issue.

Are you aware of anything I can do to remove this requirement?

2 Likes