Visual Studio 2019 and CUDA 10.1

Hello developer and programmer :-) Someone have tried CUDA 10.1 with visual studio 2019? I have tried it but I am in trouble. I can see the Nsight monitor in solution explorer I can also access to it. The big problem is that I do not see anywhere the project template of Nvidia. If I open a project already done with visual studio 2017 for example, visual studio 2019 can open the files with cpp extension but not the kernel file. I tried to remove and install cuda, visual studio couple of time but the solution is always the same. Some one have some idea about what is happening with visual studio 2019? If I understand correctly in the Nvidia documentation CUDA should be compatible with the new IDE! Thank you in advance for the help! Luca

Good News!
This problem has been addressed and is available with the CUDA 10.1 Toolkit, released in February 2019.

Sorry for the long wait.

Ref:2396234

Thank you very much! I will try it

I have tried downloading the latest Cuda and I still can not find project templates.

1 Like

Same here…

Did you try searching for ‘CUDA’ in the ‘Search for project templates’ field at the top? It should be accessible from there. Unfortunately VS 2019 does not yet support 3rd parties extending the Language, Platform, or Project type drop-downs, so the search is the easiest way to find it.

Ah ok is not supported yet! I was thinking that there was some kind of problem in my vs installation!

Tired the search but no luck. I typed CUDA but shows nothing.

Sorry I misspoke. I thought this was available in the current toolkit release, it’s in an upcoming release.

In the meantime here’s a project generated by the 2019 wizard you can rename and use as a starting point.
cuda-10.1-template-2019.zip (3.31 KB)

There’s another issue you may run into depending on which release of VS 2019 you’re using. The issue is that CUDA 10.1 was released while VS 2019 was in preview, but VS changed the path where build customizations are installed during this time. If you are unable to load a project or build, copy the 4 files from here:

C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.1\extras\visual_studio_integration\MSBuildExtensions

To here (assuming Professional, modify for whatever edition you have installed):

C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\MSBuild\Microsoft\VC\v160\BuildCustomizations

This issue will also be fixed in the next CUDA Toolkit release.

Can we know when will the next CUDA toolkit be released? Thanks.

I am having the same issue, in which when building one of the CUDA samples, the following appears in the output:

1>------ Build started: Project: simpleAssert, Configuration: Debug x64 ------
1>C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\MSBuild\Microsoft\VC\v150\Microsoft.Cpp.WindowsSDK.targets(46,5): error MSB8036: The Windows SDK version 10.0.15063.0 was not found. Install the required version of Windows SDK or change the SDK version in the project property pages or by right-clicking the solution and selecting “Retarget solution”.
1>Done building project “simpleAssert_vs2017.vcxproj” – FAILED.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I have tried selecting a newer SDK in “Retarget Projects” from the project’s context menu in the Solution Explorer pane, as well as selecting a newer SDK in the Properties Page for the project.

Please advise how best to move past this issue.

Would it be possible to get a ZIP file with the CUDA samples in the updated template?

Regards,
James Weaver

Can you attach a copy of the .vcxproj that produces this error? Thanks.

Elton,

I don’t see how to attach a file. Here is a link to a .vcxproj that produces the error:

Thanks,
James Weaver

The project file is still referencing Windows SDK 10.1.15063.0. To update this go to the project properties, under the General tab change ‘Windows SDK Version’. The drop-down should enumerate the SDKs that are available to you.

Thanks. I did select a new ‘Windows SDK Version’ in the project properties, but the change isn’t getting saved. Manually changing the Windows SDK Version in the file enables the sample to build now. Perhaps I have a permissions problem that I’ll work through now.

Thanks for your help,
James Weaver

My Version translate from VS 2010 to VS 2019 make link’s erreurs:
The Compiltator can’t read shrUtils32.lib:

LINK : fatal error LNK1104: impossible d’ouvrir le fichier ‘shrUtils32.lib’

If I remove it, a lot’s of function don’t works.

I compile on VS 2019 on 64 Bits

I put it in Linker C++, entries, supplementary library.

Is there a new library to sustitute to shrUtils32.lib and shrUtils32D.lib

In VS 2010, it’s work

Thank’s

start VS2019, open Help-> About Microsoft Visual Studio and check Install products - if there are no “NVIDIA CUDA 10.1 Wizards” try to re-run CUDA package launcher ( e.g. cuda_10.1.243_426.00_win10.exe)
on Install, for Advanced user, uncheck all except Visual Studio Integration and install.