no project templates in vs2017

Hello,

I hope I ended up with my question in the right subforum.
I’ve been trying to install CUDA on a fresh Windows 10(1809) system with Visual Studios 2017(15.9.5, German version) for a few days now. The installation also runs without any problems. However, the project templates are simply not installed. Is this a known bug or are there tips or experiences of others?

Greeting

No known bugs for this one, sorry to hear the templates aren’t available. I’m wondering if the files aren’t installed at all, or if they are installed but they’re not properly registered with VS for some reason. A few questions to help diagnose this:

  1. What version of the CUDA Toolkit are you installing?
  2. Do you have anything installed under C:\ProgramData\NVIDIA GPU Computing Toolkit\v10.0\extras\visual_studio_integration\CudaProjectVsWizards (assuming CUDA 10.0)? If so, what do you see here?
  3. Do you have anything installed under C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\Extensions\NVIDIA\CUDA 10.0 Wizards (assuming CUDA 10.0 and VS 2017 Pro)? If so, what do you see here?

Thanks.

Good morning,

and thank you for the answer. So the first folder exists. This can be seen in the first screenshot. The second folder does not exist. But there is the “NSight Visual Studio Edition” folder in the parent folder. I don’t know if this will help.

My version is this: cuda_10.0.130_411.31_win10

OK let’s try this:

  1. Close all running instances of Visual Studio.
  2. Go to C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\Extensions\NVIDIA.
  3. Create a directory here called CUDA 10.0 Wizards, then create a sub-directory underneath it called 10.0.
  4. In this 10.0 sub-directory, create shortcuts to:
    • C:\ProgramData\NVIDIA GPU Computing Toolkit\v10.0\extras\visual_studio_integration\CudaProjectVsWizards\2017\extension.vsixmanifest
    • C:\ProgramData\NVIDIA GPU Computing Toolkit\v10.0\extras\visual_studio_integration\CudaProjectVsWizards\Nvda.Vsip.CudaWizards.dll.pkgdef
  5. Once these shortcuts are in place, open a Visual Studio 2017 developer command prompt and run 'devenv.com /setup /nosetupvstemplates'.
  6. Re-start Visual Studio 2017 and see if the project templates are available now.

BTW you mentioned a screenshot but I didn’t see it, was there supposed to be a screenshot? Thanks.

2 Likes

Good morning,

and thank you for the answer. Yes, that’s how it works now. However, I proceeded a little differently. I previously removed all the CUDA components from my PC, copied the Visual Studio Integration package from the CUDA Installer to the folder you suggested, and then ran the installer normally. After that, the project could also be seen in the Visual Studios. It seems to me that the installer is not able to copy the package into the folder on its own. Anyway, it works now, I’m glad. Many thanks for your help;-)

OK good news! Sorry for the troubles, glad to hear that it’s working better now.

Hi,

I got the same problem here and I follow the instructions carefully, but the last step of opening the Visual Studio 2017 developer command prompt and run: ‘devenv.com /setup /nosetupvstemplates’ doesn’t work.

please note that I’m using Visual Studio Community 2017 Version 15.0.28307.665.

Run the command prompt with admin privilage