Visual Studio 2017 - Cuda 10.2 Project Type Missing

Hi,
I’ve installed cuda_10.2.89_441.22_win10, including visual studio 2017 integration however the Nvidia->Cuda project type option is missing in visual studio 2017.

I copied the MS Build extension files

CUDA 10.2.props
CUDA 10.2.targets
CUDA 10.2.xml
Nvda.Build.CudaTasks.v10.2.dll

from
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.2\extras\visual_studio_integration\MSBuildExtensions

to
C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\Common7\IDE\VC\VCTargets\BuildCustomizations

I can successfully build and run the samples and can also convert a VC++ project to cuda by adding the following to the vcxproj file.

  <ImportGroup Label="ExtensionTargets">
      <Import Project="$(VCTargetsPath)\BuildCustomizations\CUDA 10.2.targets" />
  </ImportGroup>

I also tried VS 2019 and the same problem exists.

Can someone help me resolve this issue please.

Hi @marc.armstrong

Have you tried re-installing CUDA?

Regards,
Leon

Thanks for your response. Yes I tried reinstalling Cuda but this made no difference. For info, this entailed running the executable again. I don’t know if this removed the initial installation first. Perhaps it needs to be a complete removal then install.

This may help you:

https://docs.nvidia.com/cuda/cuda-installation-guide-microsoft-windows/index.html

Regards,
Leon

Thanks, I’ve been using this guide, and have tried another reinstall but no luck. As a workaround I can manually modify the vcxproj file. This is not too much of an inconvenience.