Cannot Install Cuda 9.0 Toolkit on Jetson TX2

I don’t know whats going i tried to install cuda toolkit 9.0 via command line and/or via Jetpack 3.2,
but it was not possible because i am getting following output from the Jetpack Installer, it’s almost the same if i do the same from the command line.

Copying /home/development/Filestorage/downloads/JetPack/jetpack_download/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb file to target…
/etc/ssh/ssh_config: line 57: Bad configuration option: permitrootlogin
/etc/ssh/ssh_config: terminating, 1 bad configuration options
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(226) [sender=3.1.1]
nvidia:
(Reading database … 185701 files and directories currently installed.)
Preparing to unpack …/cuda-repo-l4t-9-0-local_9.0.252-1_arm64.deb …
Unpacking cuda-repo-l4t-9-0-local (9.0.252-1) over (9.0.252-1) …
Setting up cuda-repo-l4t-9-0-local (9.0.252-1) …
Get:1 file:/var/cuda-repo-9-0-local InRelease
Ign:1 file:/var/cuda-repo-9-0-local InRelease
Get:2 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208 InRelease
Ign:2 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208 InRelease
Get:3 file:/var/visionworks-repo InRelease
Ign:3 file:/var/visionworks-repo InRelease
Get:4 file:/var/visionworks-sfm-repo InRelease
Ign:4 file:/var/visionworks-sfm-repo InRelease
Get:5 file:/var/visionworks-tracking-repo InRelease
Ign:5 file:/var/visionworks-tracking-repo InRelease
Get:6 file:/var/cuda-repo-9-0-local Release [574 B]
Get:7 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208 Release [574 B]
Get:8 file:/var/visionworks-repo Release [1,999 B]
Get:9 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:10 file:/var/visionworks-tracking-repo Release [2,008 B]
Get:6 file:/var/cuda-repo-9-0-local Release [574 B]
Get:7 file:/var/nv-tensorrt-repo-ga-cuda9.0-trt3.0.4-20180208 Release [574 B]
Get:8 file:/var/visionworks-repo Release [1,999 B]
Get:9 file:/var/visionworks-sfm-repo Release [2,003 B]
Get:11 file:/var/visionworks-repo Release.gpg [819 B]
Get:10 file:/var/visionworks-tr
-ports xenial InRelease
Hit:17 http://ports.ubuntu.com/ubuntu-ports xenial-updates InRelease
Hit:18 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease
Hit:19 http://ports.ubuntu.com/ubuntu-ports xenial-security InRelease
Hit:20 http://ppa.launchpad.net/ubuntu-toolchain-r/test/ubuntu xenial InRelease
Reading package lists… Done
Reading package lists… Done
Building dependency tree
Reading state information… Done
libfreeimage-dev is already the newest version (3.17.0+ds1-2).
libgomp1 is already the newest version (8-20180424-0ubuntu1~16.04.1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
cuda-toolkit-9-0 : Depends: cuda-samples-9-0 (>= 9.0.252) but it is not going to be installed
Depends: cuda-documentation-9-0 (>= 9.0.252) but it is not going to be installed
libopenmpi-dev : Depends: libopenmpi1.10 (= 1.10.2-8ubuntu1) but it is not going to be installed
Depends: libibverbs-dev (>= 1.1.7) but it is not installable
openmpi-bin : Depends: libopenmpi1.10 but it is not going to be installed
Connection to 192.168.171.47 closed.
dpkg-query: package ‘cuda-toolkit-9-0’ is not installed and no information is available
dpkg-query: package ‘libopenmpi-dev’ is not installed and no information is available
dpkg-query: package ‘openmpi-bin’ is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
2
Error: CUDA cannot be installed on device. This may be caused by other apt-get command running on device when installing CUDA. Please use apt-get command in a terminal to make sure following packages are installed correctly on device before continuing:
cuda-toolkit-9-0 libgomp1 libfreeimage-dev libopenmpi-dev openmpi-bin
After these packages are installed on device, press Enter key to

It’s really annoying because installing from command line does not work and installing from Jetpack does not work, btw this was my second try to install all needed drivers, i always got troubles to install cuda toolkit 9.0 because display drivers are missing and so on. And it’s not possible to install easily the needed stuff.

Best regards

Hi,

Based on the log, the installer hits error since other application is occupying the apt-get.
Could you re-flash the device and wait for all libraries are well-installed.

By the way, you don’t need to manually setup any display driver for Jetson.
All the requirements are included into JetPack.

Please give it a try and let us know the results.
Thanks.

Ok thx,
but i already did it. So it means my first try was already a failure.
Is it maybe a problem to start the installer (.run) remotely ? And should it be better to start the installer from the GUI ?.

Best regards.

Jetsons were intended to have CUDA installed from a remote PC running JetPack. If you were logged in to your PC remotely and then that PC was doing the install there could be problems due to X11 forwarding. Were you physically at the computer which was running JetPack? If so, then this is correct procedure.

If you are using a CUDA (non-JetPack) “.run” file on a PC then you must be at the computer accepting the install.

Thanks linuxdev !

Hi, markus.gruber4
Could you try the suggestion of linuxdev and let us know if error still occurs?

Hi there !

I’ve had a lot of trouble installing CUDA9.0 too on my Jetson(s).

Here’s the thing. IMO, jetpack doesn’t show clearly enougb how important it is for your jetson to be turned on before the install, and that it has to be plugged in into a monitor to know what’s going on.

Oh and same for the fact that it needs to be connected to the host computer through the host or a switch.

In my case, a switch didn’t work and i had to connect it to my router.

in the end, following this (a little outdated but fine) tutorial helped me a lot https://www.youtube.com/watch?v=D7lkth34rgM

At first, I wasn’t doing the steps after the IP lookup because it’d get stuck and the setup would crash. ubuntu would be installed but not cuda

hope this help <3

Hi,

Thanks for sharing the video with us.
The video from JetsonHacks is helpful. : )

Hi,

No problem ! I had a lot of troubles myself to have a correct install (HINT HINT MAKE MORE FREAKIN DOC)

Let me know if you have any more trouble

I have meeted the same problem. How to resolve it?

@Ge-Baoshan Hi, Did you try to follow the video I sent step by step ?

Video is for Jetpack 3.0 @Jules Lasne.

Please provide steps for Jetpack 3.2.1 for the mentioned error in @markus.gruber4 quary. I’m also facing the same issue.
Thank you.

Hi @srikanth.sambi, Yes I know and i’ve mentionned the tutorial was outdated but works. Follow the same tutorial with 3.2.1 and it will work too.

(This is @Seluj78, I just cannot login to my old account for a weird reason, @nvidia please fix.)

Hi, jules.lasne

Do you mean you cannot log in the Jetson forum?
Is this issue fixed now?

Thanks.

Hi AastaLLL. Yes that means I cannot login with my old account on the forums… You guys changed the login system and I can’t even reset the password of the old account. The email is correct, jules@unsupervised.ai. I have access to it but I didn’t get anything. I still get emails from replies to this email adress but I can’t login.

In the “newer” login system you have to recreate the same name and details. I was lost at first because I had a somewhat zoomed in web browser and the bottom of the “new” login pop-up (which is quite important) was cut off with no scroll bars. It wasn’t until I discovered my mouse wheel scrolled down on this login pop-up that I found a way to do this. Have you tried to recreate the account with the same name/email/pass which you had before?

Hi jules.lasne,

You could also try to clean the browser cache and cookie if still have the login issue.

Thanks

I have solved this issue finally.

In corporate environment:

As soon as you see the full display in the monitor attached to the Jetson Tegra TX2 GPU(Target system), then you need to run following lines,
1)Run-> sudo apt-get update
2)Set-> 01proxy in etc/apt/apt.conf.d(You need to copy 01proxy file using scp command, otherwise you will end up with cuda error again. Mostly, system will wait for 2 to 5 seconds to get xenial ports to update)
3)Set-> corporate proxy address in ./bashrc (Ex: export HTTP_PROXY=http://usrname:id@…com:portnumber)
4)Run -> sudo apt-get update

PS: First 2 steps need to be done as soon as you observe the system is fully up instruction in the host system.

Thank you.

Good to know this and thanks for the feedback.

i guess this post can be closes but btw, network connection is really crucial, i succesfully installes jetpack 2.3.1, i just did it twice but the funny thing is, at one jetson tx2 it was easy on the other one i did it several times by the same way.