Cannot load nvidia drivers

I have a problem loading nvidia drivers. I just installed Ubuntu 18.04. However, I cannot figure out what is creating the problem. Please help…
nvidia-bug-report.log.gz (85.7 KB)

Please check if you have a file /lib/modprobe.d/blacklist-nvidia.conf and delete it, then run
sudo update-initramfs -u
and reboot.

I have these files:

aliases.conf fbdev-blacklist.conf
blacklist_linux_4.15.0-42-generic.conf nvidia-graphics-drivers.conf
blacklist_linux_4.15.0-43-generic.conf systemd.conf

According to the logs, you’re running Ubuntu 16.04, not 18.04.

  • Please upgrade your HWE stack to the current one using
sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

https://wiki.ubuntu.com/Kernel/LTSEnablementStack

  • Also, remove the nomodeset parameter from grub config, you have an Optimus system which doesn’t work with this set. Reboot.

  • Check if secure boot is enabled in bios and disable it.

  • Make sure the package nvidia-prime is installed and run
    sudo prime-select nvidia

  • Please post the output of
    grep blacklist /etc/modprobe.d/* /lib/modprobe.d/*

This is the output of the last instruction:

lib/modprobe.d/fbdev-blacklist.conf:blacklist pm2fb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist pm3fb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist s3fb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist savagefb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist sisfb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist tdfxfb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist tridentfb
/lib/modprobe.d/fbdev-blacklist.conf:blacklist vt8623fb
/lib/modprobe.d/nvidia-graphics-drivers.conf:blacklist nouveau
/lib/modprobe.d/nvidia-graphics-drivers.conf:blacklist lbm-nouveau

Also can you send me some more details on step 2 and 3?I am quite new to Ubuntu and I am not sure of how to proceed.

I disabled secure boot.

To remove the nomodeset kernel parameter:
https://askubuntu.com/questions/19486/how-do-i-add-a-kernel-boot-parameter

Install nvidia-prime:
sudo apt install nvidia-prime

Please create a new nvidia-bug-report.log after you made the changes and rebooted.

In this config file i have something like this: GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”.

Please create a new nvidia-bug-report.log and attach.

This is the bug report.

nvidia-bug-report.log.gz (1.05 MB)

In your first post, you attached a log from April last year when you were running a broken 16.04 install. So everything I was telling you didn’t apply.
Now you attached the correct logs from your current 18.04 install. Everything looks correct, do you still have issues?

No, I do not have issues. I applied all the changes

Ok, fine you worked it out. So it was just the secure boot setting?

I think this was the problem