Cannot read or write through UART serial port on 40 pin headers

We have been trying to read and write on the UART port of the Jetson (pins 8 and 10). The 40 pins header is configured with uarta on these two pins, and should be on dev/ttyTHS1. We have tried to run a simple python script which writes a dummy message to the serial port. The port is configured at a baud rate of 115200 with no parity and one stop bit. We have verified that the port is open (serial_port.is_open returns True in the python script) but no signal can be measured with an oscilloscope on the TX pin.

We are using minicom to try and read from the RX pin (we are sending data from a microcontroller at 3.3V logic, with shared grounds) but we also receive nothing. We’ve also tried to disable nvgetty and rebooting the Jetson. We are also currently running Jetpack 4.6.

Thank you for your help.

We’ve also tried to directly set the GPIO pins using the Jetson.GPIO python library, but no signal can be measured (we used pin 13 with BOARD pin numbering)

hello vincen7.nguyen,

IIRC, it’s ttyTHS3 to communicate with Xavier NX, please have a try, thanks

There is no ttyTHS3 port. Looking at other posts, it seems like uarta (what we use) is ttyTHS0 and uartb is ttyTHS1. We’ve tried to read both ports but had no success. We suspect this is also a consequence of the fact that we can’t read/write to any of the GPIOs on the Jetson

What do you see from:

dmesg | grep ttyTHS
ls -l /dev/ttyTHS* /dev/ttyS*

hello vincen7.nguyen,

please access Jetson Xavier NX Product Design Guide and check [Figure 12-5. UART Connections].
there’re total 3 UARTs available.
from software side, these UARTs were registered as below.
uart-1 / uart-a / serial@3100000
uart-2 / uart-b / serial@3110000
uart-3 / uart-c / serial@c280000

you may also check $ dmesg | grep ttyTHS for the register serial console, thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.