Can't boot Ubuntu 22.04 after installing Nvidia 525 or 530 drivers (RTX 4090 laptop)

Greetings. So my Ubuntu 22.04 stops booting immediately after I install 525 or 530 drivers. My GPU is RTX 4090 mobile.

Each boot gets stuck at this screen (image 1 below), which in normal circumstances is immediately followed by a splash screen. Trying to Ctrl+Alt+F4 into console takes me to an unresponsive black screen with a blinking cursor (also display backlight starts flickering for some reason).
If I wait for a few minutes, several other errors appear (image 2). Seemingly related to “plymouthd” and “gpu-manager”.

Secure Boot is disabled. Wayland is disabled, kernel headers are installed. Installing a kernel from the liquorix repo (prior to installing the drivers) did nothing.

I had to boot into recovery mode root prompt in order to run, and I can’t even start the X server prior to that because it freezes.

Any help is appreciated.

nvidia-bug-report.log.gz (343.3 KB)

Screenshot from 2023-05-12 23-36-38

Alright, I think I resolved this. I disabled the Plymouth splash screen and then reduced the timeout on the service called systemd-backlight@backlight:nvidia_0.service. Both tweaks seem to be necessary, since neither of them does the job without the other.

In general, it’s probably a bad idea to mess with random services, but I identified this one by watching the messages during boot (which became visible thanks to Plymouth being disabled). On every boot, this service was taking its goddamn time and preventing another service from starting, which is “Detect the available GPUs and deal with any system changes”. So this is why I decided to mess with it.

This systemd-backlight@backlight:nvidia_0.service service now fails to start most of the time, but that doesn’t seem to affect anything. I can boot, the GPU is recognized and actually usable.

Here’s the whole thing, in case anyone else finds it useful.

  1. First I reinstalled Nvidia drivers for the 9000th time. I’m not sure if it’s necessary, but just in case I did this in the most thorough way I can imagine:
sudo apt remove --purge *nvidia*
sudo apt install --install-recommends linux-generic
sudo apt install --install-recommends linux-modules-nvidia-530-generic linux-modules-nvidia-530-5.19.0-41-generic
sudo apt install nvidia-driver-530 nvidia-dkms-530
sudo apt install linux-headers-5.19.0-41-generic

Here, 5.19.0-41-generic should be replaced with your kernel version, obtainable with uname -r. Can also use sudo apt list | grep linux-modules-nvidia-530-5.19.0-41* to verify that the right linux-modules-nvidia package is actually available.

  1. Disable Plymouth by replacing quiet splash with nosplash noplymouth in /etc/default/grub, then run sudo update-grub.

  2. Edit the service with sudo systemctl edit systemd-backlight@backlight:nvidia_0.service. I’m not entirely sure how to do this right, so I just copied the content of /lib/systemd/system/systemd-backlight@.service, inserted it between the two comments in the editor, and changed TimeoutSec to 5. Then run sudo systemctl daemon-reload and reboot.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.