Can't build bandwidthTest.cu sample with CUDA 4.0

Hi!

I have win7 64bit, VS2010 and GTX460. I’ve downloaded CUDA Toolkit 4.0 RC2, GPU Computing SDK and developer driver.

when i open bandwidthTest_vs2010 and compile sample “bandwidthTest.cu” I get errors like: LNK1104: cannot open file ‘shrUtils32D.lib’.

Trying to create missing libraries I’ve compiled shrUtils project with error: Cannot open source file src/stopwatch_win.cpp and stopwatch.cpp. These files simply do not exist in SDK.
Also oclUtils build results in error: cannot open input file shrUtils32d.lib.

I am not familiar with CUDA. I also was not able to install CUDA3.2 because I have only VS2010 and VS2008 projects could not be successfully converted to VS2010 projects.
I also tried to set up 2010 project by myself using links I found on internet. This attempt fails on error LNK1120: 31 unresolved externals.

Please help. I really want to use CUDA.

Regards

Roman

It seems you need to set Target Platform as “x64”, not “Win32”. As far as i know(by reading this forum), compiling Win32 cuda application on x64 OS is rather difficult.

I have the same error and I made sure set it to X64.