Can't build samples on Win 7 x64, MSVC 2008

Hello, I’m a newbie in CUDA world, please help.
Just got gtx 470, install CUDA 3.0 with the last official drivers, but can’t compile any CUDA program and the error seems to be this: “–name: No such file or directory”. Where that “–name” come from?

1>------ Build started: Project: MersenneTwister, Configuration: Debug x64 ------
1>Compiling with CUDA Build Rule…
1>“F:\CUDA\bin64\nvcc.exe” -m64 -ccbin “F:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” -D_DEBUG -D_WIN32 -I"F:\CUDA\include" -I"./" -I"…/…/common/inc" -I"…/…/…/shared/inc" -I"F:\CUDA\include" -I"…/…/common/inc" -I"…/…/…/shared/inc" -Xcompiler "/EHsc /W3 /nologo /Od /Zi /MT " -maxrregcount=32 -gencode=arch=compute_10,code=“sm_10,compute_10” -gencode=arch=compute_20,code=“sm_20,compute_20” --compile -o “x64\Debug\MersenneTwister.cu.obj” “f:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK\C\src\MersenneTwister\MersenneTwister.cu”
1>MersenneTwister.cu
1>tmpxft_00001250_00000000-6_MersenneTwister.compute_20.cudafe1.gpu
1>tmpxft_00001250_00000000-10_MersenneTwister.compute_20.cudafe2.gpu
1>MersenneTwister.cu
1>tmpxft_00001250_00000000-3_MersenneTwister.compute_10.cudafe1.gpu
1>tmpxft_00001250_00000000-14_MersenneTwister.compute_10.cudafe2.gpu
1>–name: No such file or directory
1>bin2c: cannot open Project : error PRJ0019: A tool returned an error code from “Compiling with CUDA Build Rule…”
1>Project : error PRJ0002 : Error result 1 returned from ‘F:\windows\system32\cmd.exe’.
1>Build log was saved at “file://f:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK\C\src\MersenneTwister\x64\Debug\BuildLog.htm”
1>MersenneTwister - 1 error(s), 0 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

have you got an answer?

My error is the same: ( but on win 7, x64 )

1>------ Rebuild All started: Project: simpleD3D9, Configuration: Debug x64 ------
1>Deleting intermediate and output files for project ‘simpleD3D9’, configuration ‘Debug|x64’
1>Compiling with CUDA Build Rule…
1>“C:\CUDA\bin64\nvcc.exe” -arch sm_10 -ccbin “c:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\bin” -Xcompiler “/EHsc /W3 /nologo /Od /Zi /MT " -I"C:\CUDA\include” -I"…/…/common/inc" -maxrregcount=32 --compile -o “x64\Debug\simpleD3D9_kernel.cu.obj” “c:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK\C\src\simpleD3D9\simpleD3D9_kernel.cu”
1>simpleD3D9_kernel.cu
1>tmpxft_00000bac_00000000-3_simpleD3D9_kernel.cudafe1.gpu
1>tmpxft_00000bac_00000000-8_simpleD3D9_kernel.cudafe2.gpu
1>–name: No such file or directory
1>bin2c: cannot open
1>Compiling…
1>cl : Command line warning D9035 : option ‘Wp64’ has been deprecated and will be removed in a future release
1>rendercheck_d3d9.cpp
1>Compiling…
1>cl : Command line warning D9035 : option ‘Wp64’ has been deprecated and will be removed in a future release
1>simpleD3D9.cpp
1>Linking…
1>LINK : fatal error LNK1181: cannot open input file ‘.\x64\Debug\simpleD3D9_kernel.cu.obj’
1>Build log was saved at “file://c:\ProgramData\NVIDIA Corporation\NVIDIA GPU Computing SDK\C\src\simpleD3D9\x64\Debug\BuildLog.htm”
1>simpleD3D9 - 1 error(s), 2 warning(s)
========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

F: is pretty unusual for a Windows system drive, and might have something to do with the problem you are having. Can you explain why it’s F: and not C:?

The error was fixed after I upgrade to CUDA 3.1. I highly doubt that the problem was in the drive letter.
Why F?.. I added a new disk and made it a system one, but it ends for some reason “F”. And there is no way any more the letter to be changed… At least I don’t know one… I had problems only with some installation which by default unzip their files on c:\ and leave them there.

The error was fixed after I upgrade to CUDA 3.1. I highly doubt that the problem was in the drive letter.
Why F?.. I added a new disk and made it a system one, but it ends for some reason “F”. And there is no way any more the letter to be changed… At least I don’t know one… I had problems only with some installation which by default unzip their files on c:\ and leave them there.