Can't communicate with I2C GP2

I have an application where I (currently) need to access the I2C GP2 bus but haven’t been able to do that so far. I have verified that I can communicate in some manner with GP0, GP1, and GP3 by using i2cdetect and looking for clock signals with my oscilloscope but I see nothing for GP2. I’m currently working with the TX2 development kit so this isn’t an issue with custom hardware.

  1. Is there some sort of config file that I need to set up to enable this bus?

  2. Am I just looking at the wrong port through i2cdetect? I have found that GP1 is on bus 0, GP0 is on bus 1, and GP3 is on bus 8. i2cdetect -l shows available busses from 0 to 8 and 40 to 47. I’ve tried them all but maybe I’m missing something?

Any help that can be provided would be appreciated.

The bus # is correct. Could you tell where did you probe?

There is a connector labeled J26 on the top right side of the dev board as it is shown on page 5 of the development kit user guide.

I probed pins 12 and 14 which correspond to SCK and SDA respectively. The other ports didn’t require pull up resistors as there must have been one already somewhere else on the board. These pins sat low all of the time so I put in some pull up resistors to 1.8V. I didn’t see any signal so I tried again without the resistors just in case something was strange about these pins. I still didn’t see anything on them though.

There are internal 1.8V pull-up in module as other I2Cs, have you change the pinmux?

Hi jacksmfht,

Have you managed to get issue resolved? Any result can be shared?