Can't flash nvme drive with SDK


Fail to flash the nvme drive on a Jetson Orin Nano 8Gb.

Set the recovery jumper => ok
Plug USB + PWR => ok
See the jetson on Ubuntu 20.04 (lsusb) => ok
SDK installation => ok
SDK: Product Category => jetson orin nano ok
SDK: target board: Jetson Orin Nano devkit => ok
SDK: Flash menu: Manual Setup & select nvme drive => ok
Prepare image & other stuff (green bard) => ok
Writing nvme drive => Fail => no drive found

What did I miss?

Do I need to fomat the nvme drive first (ext4?)?

Thank in advance


Some similar issues were solved by formatting the NVME drive to contain a single ext4 partition, then plugging it back again and re-trying the flashing procedure.
Please have a try. Thanks

Thanks a lot,

I don’t have ssd free port on my laptop.

  • After work, I plan to flash Jetson Orin Nano on SDcard then format SSD NVME from the Jeston Nano .

  • Or, maybe there is a way to directly format the nvme from the computer host?

Then flash NVME from SDK.

Hi, there’s some SSD enclosures available on the market, so you can plug-in your SSD to a PC via USB, but as it comes with extra money, I think your first choice sounds reasonable.

That’s exactly what I was looking for on some market place :)

Or maybe mount the SSD on my laptop and format it with a linux live.

Thanks for the answer, I’ll be back with the result.


Finally get an DVI-HDMI adapter the continue the installation.

1/ Format 2 SSD M2 ext4 (Kingston and Hynix both non-nvme)

2/ Running SDK managerand follow the guidance.

3/ Fail flash at around 50%

Here the last log lines:

15:55:53 INFO: Flash Jetson Linux - flash: writing item=1, 9:0:primary_gpt, 512, 19968, gpt_primary_9_0.bin, 16896, fixed–0, 2b8f050ff088933c5faf8c44c7ecb00d740aea7b
15:55:53 ERROR: Flash Jetson Linux - flash: Error: Could not stat device /dev/nvme0n1 - No such file or directory.
15:55:53 INFO: Flash Jetson Linux - flash: Flash failure
15:55:53 INFO: Flash Jetson Linux - flash: Cleaning up…
15:55:53 INFO: Flash Jetson Linux - flash: [ Component Install Finished with Error ]
15:55:54 ERROR: Flash Jetson Linux - flash: command terminated with error
15:55:54 SUMMARY: DateTime Target Setup - target: Depends on failed component
15:58:37 SUMMARY: Compute Sanitizer - host: Install completed successfully.
15:59:31 SUMMARY: Drivers for Jetson - target_image: Install completed successfully.
16:03:32 SUMMARY: File System and OS - target_image: Install completed successfully.
16:11:55 SUMMARY: DateTime Target Setup - target: Depends on failed component

Same for both SSD.

Maybe the SSD M2 have to be exclusivelly nvme ?

Thank in advance,


What kind of device is that if that is not nvme? SATA SSD? We don’t support SATA on Orin.


SSD M2 and pretty sure they are not NVMe by now.

Hynix hfs256g39tnd-n210a bb
Kingston SUV500M8/240G

I’ve install the OS on a SDD card => work well.
I’ve add the SSDs and none of them can be seen by the jetson (lsblk).

So I’m planing to buy a SSD NVMe.

Could you advice me about some Jetson Orin compliante SSD M2 NVMe ?

Or maybe a list of compliante SSD is avaible?

Thank in advance,


I just used this Samsung 970 SSD (PCIe Gen. 3) and it worked fine for me.

From what I read, the Orin Nano Dev Kit can handle up to PCIe Gen. 3 SSD only, even though the physical PCIe bus on the Dev Kit carrier can handle PCIe Gen. 4 SSD if one happens to use an Orin NX module.

Thank a lot,

@roboteer, I’ve order the same SSD (take 500Go for quite the same price).

I’ll get it the 04/05.

Did you need to format it as ext4 before flashing? I am using exact same SSD as this but getting same errors as OP

I used AOMEI Partition Assistant (free version) to create a GPT disk and formatted the entire disk as EXT4 before I connected it to the PCIe bus on the carrier board.
SDK Manager did not give me any error during the entire flashing procedure.

The link to AOMEI Partition Assistant is

Thanks all for your help. Just to say I did get mine to eventually flash properly with pre-format ext4, though there were various other issues; for example I needed to plug it into a different USB port on my host PC (they could ALL recognise the device in SDK Manager but evidently only SOME ports were able to do the flashing)


Good to know that some host port could’nt flash it.


Receive the Samsung NVME SSD and formt it.

Everything run perfectly.

Conclusion for install
SSD have to be M2 NVME
Format the SSD (ext4) before install (Jetston can’t see unformated HDD)
Some host PC USB port can’t flash the Jetson (credit @HS131231)
Don’t forget to remove the jumper before clicking on flash (as describe on the SDK launcher)

Have a nice day

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.