Can't get Nvidia drivers to work, Quadro M1200 (HP ZBook 15 G4), Ubuntu 18.04

Background

I have spent hours trying to install Ubuntu 18.04 on HP ZBook 15 G4. I was able to finally install it thanks to this post: https://ubuntuforums.org/showthread.php?t=2328988
Solution for me was to run installer with ‘acpi=off’ in the grub.

Also, these are the changes I made to my UEFI/BIOS:
I unchecked “Enable MS UEFI CA key”
Disabled secure boot
Changed graphics from Hybrid to Discrete (Nvidia drivers will fail to install otherwise)
Unchecked “Runtime Power Management”

Problem

Now, I can’t get Nvidia drivers to work. Without the drivers everything seems to work fine, however when I install Nvidia drivers (be it manually, or through software center 3rd party, or apt repository) none of the display managers (gdm, lightdm, sddm) will boot. I am also blacklisting nouveau, otherwise I get into this login loop. Long story short, any attempts to install Nvidia drivers are futile and result in a black screen during boot (I still can get into terminal though).

I feel like I have tried everything I was able find on forums. I am tired and hopeless, I call upon you oh great ones.

Reinstalling, and trying different versions of Ubuntu does not help.

Additional Info:

Driver version I have been trying: NVIDIA-Linux-x86_64-390.59
Everything looks good in the ‘/var/log/nvidia-installer.log’ after installation.
sudo lshw -C display

Outputs:
*-display
description: VGA compatible controller
product: GM107GLM [Quadro M1200 Mobile]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a2
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:10 memory:e3000000-e3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:5000(size=128) memory:c0000-dffff
However even after successful install of the driver, nvidia-smi outputs “No devices were found”.

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post will reveal a paperclip icon.

I was able to get it to work after trial and error. Here is my solution:

In UEFI:

    Disable MS UEFI CA key Disable secure boot Changed graphics from Hybrid to Discrete (Nvidia drivers will fail to install otherwise) Disable SGX -Intel Software Guard Extension (This might be the root cause of many issues) Clear Secure Boot keys

I also changed the grub launch of the Ubuntu installer using ‘pnpacpi=off’