Ubuntu 20.04 and NVIDIA not working … again!

Hi to all!

A old problem has returned:

I have a HP Zenbook with a 4 GB NVIDIA RTX A2000 and Intel UHD Graphics.

When I boot from a Ubuntu pen it defaults to the Intel UHD Graphics, and I can use 2 monitors.

After default install I have only access to the computer’s monitor.

In a previous installation after the install of NVIDIA divers everything was ok, the GPU was working and I could use an external monitor.

But it stop working. So I decided to make a new ubuntu installation but now I can’t get the NVIDIA driver working.

After the original post i followed the suggestions from generix and I was able to get 2 monitors working and NVIDIA Driver was ok.

A few days ago, it stopped again. I can’t use the second monitor (attached to hdmi)

I have tried to recreate the previous solution and even reinstalled kernel 5.11.0-27 (the one working previously) but with no success.

The computer boots but with no graphical login window…

I can use tty2, 3,…

I have tried to uninstall the nvidia drivers reinstall using gui and command line, but nothing works.

I always get “Mesa Intel® UHD Graphics (TGL GT1)”

Any help?

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Thanks (again) for your reply.
I’ve managed to properly install kernel 5.11.20-051120-generic using mainline tool (from sudo add-apt-repository ppa:cappelikan/ppa).
So, now I have again graphic login and multi-monitor. But still no NVIDIA working…
Please find attached the result from nvidia-bug-report.sh.
nvidia-bug-report.log.gz (358.7 KB)


There doesn’t seem to be a driver installed for that kernel. Please (re)install the headers
sudo apt install --reinstall linux-headers-$(uname -r)
and check the output of
dkms status
if the driver gets installed.

BTW, there seems to be a new bios update released by HP for your model, please check if that fixxes the issue with the failing kernels.