GPU not detected after briefly using the Intel GPU (Ubuntu 18.04, RTX 2080ti)

It happened when I tried to set up dual monitors.
I have an RTX2080ti with 3 HDMI and 3 display ports; I was using a single monitor connected via HDMI. Then I tried adding a second one but I didn’t have any other cable than a VGA at the moment so I plugged it in the mainboard GPU which is “Intel Corporation UHD Graphics 630 (Desktop 9 Series) (rev 02)”.
Then I found out that I need to actually plug the monitors into the same GPU; got a DVI-to-HDMI cable for the second monitor (no HDMI ports on that monitor) and plugged it in the RTX. Nothing happened. Reboot. Now even the first monitor wasn’t working. After some switcheroo on the RTX ports and multiple hard reboots, I plug one of the monitors back into the Intel GPU and it works. But the RTX GPU doesn’t work anymore.

This one is the closest to my problem I think - nvidia rtx 2080 ti - dual monitor stopped working - smi driver not loaded - ubuntu 18.04.2

I followed the steps proposed there and here are the outputs:

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:# generated by nvidia-installer
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=0

no blacklist nvidia file
did sudo update-initramfs -u and reboot

This is the output of
modinfo nvidia

filename: /lib/modules/5.3.0-53-generic/updates/dkms/nvidia.ko
alias: char-major-195-*
version: 440.82
supported: external
license: NVIDIA
srcversion: 058C3165C621D73A1F7436F
alias: pci:v000010DEdsvsdbc03sc02i00
alias: pci:v000010DEdsvsdbc03sc00i00
depends: ipmi_msghandler
retpoline: Y
name: nvidia
vermagic: 5.3.0-53-generic SMP mod_unload
signat: PKCS#7
sig_hashalgo: md4
parm: NvSwitchRegDwords:NvSwitch regkey (charp)
parm: NVreg_Mobile:int
parm: NVreg_ResmanDebugLevel:int
parm: NVreg_RmLogonRC:int
parm: NVreg_ModifyDeviceFiles:int
parm: NVreg_DeviceFileUID:int
parm: NVreg_DeviceFileGID:int
parm: NVreg_DeviceFileMode:int
parm: NVreg_InitializeSystemMemoryAllocations:int
parm: NVreg_UsePageAttributeTable:int
parm: NVreg_MapRegistersEarly:int
parm: NVreg_RegisterForACPIEvents:int
parm: NVreg_EnablePCIeGen3:int
parm: NVreg_EnableMSI:int
parm: NVreg_TCEBypassMode:int
parm: NVreg_EnableStreamMemOPs:int
parm: NVreg_EnableBacklightHandler:int
parm: NVreg_RestrictProfilingToAdminUsers:int
parm: NVreg_PreserveVideoMemoryAllocations:int
parm: NVreg_DynamicPowerManagement:int
parm: NVreg_EnableUserNUMAManagement:int
parm: NVreg_MemoryPoolSize:int
parm: NVreg_KMallocHeapMaxSize:int
parm: NVreg_VMallocHeapMaxSize:int
parm: NVreg_IgnoreMMIOCheck:int
parm: NVreg_NvLinkDisable:int
parm: NVreg_RegisterPCIDriver:int
parm: NVreg_RegistryDwords:charp
parm: NVreg_RegistryDwordsPerDevice:charp
parm: NVreg_RmMsg:charp
parm: NVreg_GpuBlacklist:charp
parm: NVreg_TemporaryFilePath:charp
parm: NVreg_AssignGpus:charp


sudo modprobe nvidia

modprobe: ERROR: could not insert ‘nvidia’: No such device

furthermore I can’t even see the gpu with lspci:

lspci | egrep -i "vga|display|3d"

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Desktop 9 Series) (rev 02)

other things i’ve tried (in order):

prime-select query shows nvidia; also tried setting to intel and back to nvidia and rebooting

deleted /etc/X11/xorg.conf

set the nvidia-drm modeset=1 to 0 and sudo update-initramfs -u and reboot

added PrimaryGPU Yes to /usr/share/X11/xorg.conf.d/10-nvidia.conf
resulted in login loop. reverted

disabled wayland
also resulted in login loop. reverted

nvidia-bug-report.log (1.5 MB)

Doesn’t look good, seems the nvidia gpu went up in smoke. Please check if it works in another system, then RMA.

You sure? The fans are spinning, it’s glowing. Don’t have another system to test on atm

The lights are on but nobody is at home.
It’s powered but it’s not detected by the mainboard anymore, this is also why the intel gpu is enabled now. From the mainboard’s perspective, it’s dead.

Right, thanks a lot!

You could try to remove it completely and put it back in but chances are low.

1 Like

Was gonna try that. Always worked for me :) except when it didnt.

I’ll let you know

Plug it out and in again worked. And dual monitor working immediately
I suppose it’s safe to set my nvidia-drm back to 1 for that tearing issue?

That’s only for hybrid graphics, doesn’t have that effect on nvidia-only systems.

1 Like