GPU not detected Ubuntu

I reinstalled mu ubuntu OS(ubuntu 18.04) and after that i tried to check my gpu driver version with this command “lspci -v | grep VGA”

it gives

“00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09) (prog-if 00 [VGA controller])”

i have two gpus in my laptop one is Inter GPU which appears and the other one is nvidia geforces 920M
is that means there is hardware issue with my nvidia gpu?
if it’s a driver installation problems what is the right way to install my driver and what is the version should i use

Note that i tried to install a new driver from .run file and it fails.

The nvidia gpu is probably a 3D controller without outputs, it’s displayed with
lspci |grep 3D
Please don’t use the .run installer, uninstall it using the --uninstall option. Afterwards, install the driver using Ubuntu’s Software&Updates application.

I tried this but still no nvidia gpu apears
I also tried to check it from ubuntu boot device and only reads intel gpu
any other suggestions ?

lspci | egrep -i "vga|display|3d"

If this does only show the Intel GPU, the NVidia GPU is propably disabled in BIOS.

yes it shows only intel gpu

if it’s disabled on BIOS how can I enable it again

Same here i have the same gpu as adbel

I have the same problem on Ubuntu 19.10, with a rtx 1660

I suspect a problem with a broken udev rule installed by Ubuntu. Please post the output of
grep 10de /lib/udev/rules.d/*

So none of the others replied so here goes:

grep 10de /lib/udev/rules.d/*
/lib/udev/rules.d/71-nvidia.rules:SUBSYSTEM==“pci”, ATTRS{vendor}==“0x10de”, DRIVERS==“nvidia”, TAG+=“seat”, TAG+=“master-of-seat”

The weird thing is every thing worked I cant remember after what update it stopped. I don’t normally game on this laptop. So it doesn’t normally bother me

That looks normal. Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Hi @generix.

In my case, when I run lspci -v | grep VGA, the result is:

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])

and when I run lspci | grep 3D, the result is:

0a:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1)

But when I run nvidia-smi, the result is:

As you can see above, the GPU is Not Supported. How to fix this?

Thanks for helping

You just misinterprete the output. “Not Supported” means displaying processes on the gpu is not supported which is normal for most low-end nvidia gpus. The output shows the driver is correctly installed and running.

Oh I see, so my NVIDIA GPU is indeed running fine.

Thanks for the answer

Apologize for the late reply but in my case it was an hardware issue, my lap is Dell inspiron 5500 and after searching found that removing the CMOS battery for a while then plug it in again may help, but be aware to remove the main battery for a while first before removing cmos to cut in power running on the hardware, done this and the gpu appeared normally.

Is there a way to force the displaying processes on the gpu ? Kinds


I have tried all of the above commands but still, I am not getting any output
The output for grep 10de /lib/udev/rules.d/* is /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", ATTR{remove}="1" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", ATTR{remove}="1" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", ATTR{remove}="1" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x038000", ATTR{remove}="1" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="auto" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="bind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="auto" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030000", TEST=="power/control", ATTR{power/control}="on" /lib/udev/rules.d/50-pm-nvidia.rules:ACTION=="unbind", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x030200", TEST=="power/control", ATTR{power/control}="on" /lib/udev/rules.d/71-nvidia.rules:SUBSYSTEM=="pci", ATTRS{vendor}=="0x10de", DRIVERS=="nvidia", TAG+="seat", TAG+="master-of-seat" /lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x03[0-9]*", TEST=="power/control", ATTR{power/control}="auto" /lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", TEST=="power/control", ATTR{power/control}="auto" /lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c0330", TEST=="power/control", ATTR{power/control}="auto" /lib/udev/rules.d/71-nvidia.rules:ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x0c8000", TEST=="power/control", ATTR{power/control}="auto"

Please remove that file /lib/udev/rules.d/50-pm-nvidia.rules

1 Like

I did that now I am getting no output to grep 10de /lib/udev/rules.d/*
But now my output for lspci -v | grep VGA is
00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile) (prog-if 00 [VGA controller]) 01:00.0 VGA compatible controller: NVIDIA Corporation TU117M (rev a1) (prog-if 00 [VGA controller])

After reboot, please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.