can't install s870 driver on ubuntu 7.04 installation driver

hi all, i want to install s870 on my computer with QuadroFX4500 X2.

after installing ubuntu 7.04 clearly, and i set up the nvidia unified driver for s870(i tried both of 171.06.01 and 173.08 beta).
but can’t initialize s870.

both QuadroFX4500X2 and s870 card is set on MotherBoard. but ubuntu 7.04 is reconized only QuadroFX4500X2. nvidia-settings show up to me only QuadroFX4500X2 on the device list but no s870. i think ‘perhaps, this is normaly state.’ so i ignored about this, installing cuda toolkit and sdk. but i can see only ‘There is no device supporting CUDA’ message.

here are some log files about the problem.
please help me.

thx to read.

PS.
ubuntu is for x64.

http://www.navisphere.net/Xorg.0.log
http://www.navisphere.net/nvidia-bug-report.log
http://www.navisphere.net/xorg.conf

According to your bug report, the S870 doesn’t appear on the PCI bus. Assuming that you’re certain that the S870 is fully cabled up correctly, this looks like a BIOS or kernel bug. Do you see the S870 cards listed in lspci output?

It looks like you’re using a BIOS from 2006, so you might verify that you have the most recent. If so, then testing with a much more recent kernel might be a useful experiment.

thx for answer.

when i update to lastest bios. it can’t boot that starting bios. only black screen. so i updated to 2nd bios i can boot successful.

but linux isn’t running. everything is ok but, when the time in starting gdm, system be going to reset.

is it Xorg.conf problem?

here are new logs that adding “lspci > lspci.log”

thank you for reading my article and help me again, please.

http://www.navisphere.net/log2/Xorg.0.log

http://www.navisphere.net/log2/nvidia-bug-report.log

http://www.navisphere.net/log2/xorg.conf

http://www.navisphere.net/log2/lspci.log

Updating the BIOS appears to have fixed the S870 detection problem. However, at this point, this looks like an X driver issue, which shouldn’t directly impact your usage of CUDA. Are you able to run any CUDA applications?

when i run cuda example code in CUDA SDK, only ‘There is no device supporting CUDA.’ message.

In that case, there may well be additional BIOS bugs getting in the way here, or it could be a kernel bug. Have you tested with a more recent kernel?

You stated that the OS wouldn’t even boot with the latest BIOS. Have you reported that problem to the motherboard vendor or Ubuntu?

um. ok i will try it by fedora7. i found the report that success to install s870 on fedora7.

anyway, i think it is xorg.conf problem. if you use s870, could you show your xorg.conf to me?

CUDA doesn’t have any dependencies on X. This is not an xorg.conf problem, its an issue specific to your environment (either the BIOS and/or kernel).

i tried on fedora 7(2.6.23.15-80) and modified some BIOS option. suddenly, i success to see S870 card on nvidia-bug-report.

please, look at the log.

http://www.navisphere.net/log3/nvidia-bug-report.log

What should I be looking for in this bug report? What’s the current problem?

http://www.navisphere.net/log3/lspci.log

here are lspci’s result.

S870 is detected unknown device.

is this right?

PS. attached.

ignoring that unknown device message, i install cuda_sdk.

after compliing and when i run deviceQuery, system is going reset.

Yes, the unknown device message is normal ( it takes a while for new devices to show up in the list of the known pci devices)