Can't seem to set-up CUDA 10.0 with Nvidia 430.50 drivers

So as the title suggests, I have been trying to install the following: CUDA 10.0, CuDNN 7.4 so I can use my GPUs with tensorflow 2.0. I have been trying for days and I can’t seem to properly install them even though I have followed the nvidia installation tutorials. Here is my nvidia-smi output:

| NVIDIA-SMI 430.50       Driver Version: 430.50       CUDA Version: 10.1     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce RTX 2070    Off  | 00000000:01:00.0  On |                  N/A |
| 40%   26C    P8     8W / 185W |     31MiB /  7979MiB |      1%      Default |
|   1  GeForce RTX 2070    Off  | 00000000:04:00.0 Off |                  N/A |
| 41%   24C    P8     2W / 185W |      1MiB /  7982MiB |      0%      Default |
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|    0       861      G   /usr/lib/xorg/Xorg                            29MiB |


Most recently, I can’t seem to even install cuda and I have been getting the following error:

The following packages have unmet dependencies:
cuda-10-0 : Depends: cuda-runtime-10-0 (>= 10.0.130) but it is not going to be installed
Depends: cuda-demo-suite-10-0 (>= 10.0.130) but it is not going to be installed

I tried installing the first dependency and got another error:

The following packages have unmet dependencies:
cuda-runtime-10-0 : Depends: cuda-drivers (>= 410.48) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Are the cuda drivers different than the nvidia drivers? Should I be downgrading my drivers to 410.x (I noticed that’s what most people have been using/installing with cuda).

I’m also thinking it may be because I haven’t properly cleaned/uninstalled previous installations, but I have ran sudo apt-get remove cuda* and sudo apt-get purge cuda* after every unsuccessful installation, as well as removing the files in /src/local.

Hi, I have this problem too.
I tried to install nvidia-driver-410 and then using (runfile local installer) and it worked.

HOWEVER, later it crashed so badly, that nvidia-smi could not see the driver up and running and nothing else worked too. I reinstalled Ubuntu, and tried to install cuda-10.0 onto nvidia-driver-430 . Now, even after runfile local install, trying to install nvidia-cuda-toolkit only allows to install -10-2 versions of packages.