Can't uninstall 10.1

Hi,
I am trying to use tensorflow-gpu on my Linux machine. I am using Fedora 30. I already did the work around for gcc.

When I first installed the CUDA toolkit I installed 10.1 instead of 10.0. Now I am trying to uninstall 10.1 so I can get 10.0, But 10.1 seems to persist on ym system ever after uninstall.

Here is the output of all the cuda apps installed on my PC. You can see the driver and only 10.0

$ rpm -qa | grep cuda
libcudnn7-7.6.4.38-1.cuda10.0.x86_64
xorg-x11-drv-nvidia-cuda-430.40-1.fc30.x86_64
cuda-repo-fedora27-10.0.130-1.x86_64
cuda-gcc-c++-8.3.0-1.fc30.x86_64
cuda-gcc-gfortran-8.3.0-1.fc30.x86_64
xorg-x11-drv-nvidia-cuda-libs-430.40-1.fc30.x86_64
cuda-gcc-8.3.0-1.fc30.x86_64
libcudnn7-devel-7.6.4.38-1.cuda10.0.x86_64

Here is me showing that 10.1 is still somehow on my system. (Look at the top right)

$ nvidia-smi
Tue Oct 15 19:30:50 2019       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.40       Driver Version: 430.40       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce RTX 2080    Off  | 00000000:03:00.0  On |                  N/A |
| 12%   56C    P0    53W / 225W |    693MiB /  7981MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1374      G   /usr/libexec/Xorg                             55MiB |
|    0      1486      G   /usr/bin/gnome-shell                          61MiB |
|    0      1918      G   /usr/libexec/Xorg                            239MiB |
|    0      2052      G   /usr/bin/gnome-shell                         275MiB |
|    0      2726      G   ...uest-channel-token=12173677761247180250    59MiB |
+-----------------------------------------------------------------------------+

How can I fix this?

The fact that nvidia-smi reports 10.1 is OK.

https://stackoverflow.com/questions/53422407/different-cuda-versions-shown-by-nvcc-and-nvidia-smi

Based on the answer posted to that SO question I am supposed to use

nvcc -v

to check my cuda version. Unfortunately that doesn’t seems to work.

[my_usr_name@mycomp ~]$ nvcc -v
bash: nvcc: command not found...
Install package 'cuda' to provide command 'nvcc'? [N/y] n

So I tried

which nvcc

and that also says no nvcc.

[my_usr_name@mycomp ~]$ which nvcc
/usr/bin/which: no nvcc in (/home/my_usr_name/.local/bin:/home/my_usr_name/bin:/usr/libexec/python3-sphinx:/usr/share/Modules/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/home/my_usr_name/.local/bin:/home/my_usr_name/bin:/usr/local/cuda-10.1/:/usr/local/cuda-10.1/bin)
[my_usr_name@mycomp ~]$

Is it safe to just delete those file and directories?

Did you actually install CUDA 10.0?

If so, you need to follow the instructions in step 7 of the CUDA Linux install guide.

https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html

Ok. I thaught I had it installed from the file I downloaded here https://developer.nvidia.com/cuda-10.0-download-archive?target_os=Linux&target_arch=x86_64&target_distro=Fedora&target_version=27&target_type=rpmnetwork

But I guess not.

So to install one fedora I have to do

sudo dnf install cuda

.
Problem is that that wants to install the latest version and not 10.0.

===========================================================================================================================
 Package                              Architecture        Version                         Repository                  Size
===========================================================================================================================
Installing:
 cuda                                 x86_64              1:10.1.243-1.fc30               fedora-nvidia               15 M
Installing dependencies:
 nvidia-driver-cuda-libs              x86_64              3:410.104-1.fc27                cuda                        33 M
 cuda-libs                            x86_64              1:10.1.243-1.fc30               fedora-nvidia              8.9 M

Transaction Summary
===========================================================================================================================
Install  3 Packages

Total size: 57 M
Installed size: 172 M
Is this ok [y/N]: n
Operation aborted.

To install 10.0 should I just do?

sudo dnf install cuda-10-0

Yep. Read the linux install guide.

Tensorflow GPU works now. The origin of my confusion stemmed from thinking CUDA and the CUDA Toolkit are the same thing.