Unable to uninstall cuda 9.0 completely and install 8.0 instead

I installed Cuda 9.0 only to realize that tensorflow 1.3 does not yet support it.

I have tried uninstalling it but when I try to uninstall v8.0, v9.0 keeps getting installed instead.

I did
sudo apt-get --purge remove cuda
sudo apt autoremove
to remove cuda 9.0

Then
sudo apt-get clean
to clear apt-cache

Then I do
sudo dpkg -i cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb
sudo apt-get update
sudo apt-get install cuda

However cuda 9.0 keeps getting installed instead.

How do I prevent this from happening and install 8.0?

Thanks!

http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#package-manager-additional

sudo apt-get install cuda-8-0

Thanks, txbob!

I am getting this but I have not installed cuda 8.

ujjwal@ujjwal:~$ sudo apt-get install cuda-8-0
[sudo] password for ujjwal:
Reading package lists… Done
Building dependency tree
Reading state information… Done
cuda-8-0 is already the newest version (8.0.61-1).
0 upgraded, 0 newly installed, 0 to remove and 171 not upgraded.
W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Packages (partner/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en_IN) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target Translations (partner/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11 (partner/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4
W: Target DEP-11-icons (partner/dep11/icons-64x64.tar) is configured multiple times in /etc/apt/sources.list:43 and /etc/apt/sources.list.d/xenial-partner.list:4

I think you should try NVIDIA documentation
http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html#runfile-uninstallation

i have installed cuda 9.0 and operating system is centos 7. I just want to know which version of tensor flow will support cuda 9 and centos 7. Also please let me know which version of cudnn should I install?

From what I can see only Tensorflow 1.5 will support cuda9, I did the same mistake
Tensorflow 1.4 supports cuda 8 and cudnn 6

See:


https://www.tensorflow.org/install/install_linux

What about cudnn version? and tensorflow 1.5 will support cuda 9 and centos 7 both?

How can I uninstall cuda 9.0 completely and install 8.0 instead on windows

I also tried this command
sudo apt-get --purge remove ‘cuda*’
it removed all the cuda packages but didn;t help much

then finally this has helped me:

sudo apt-get autoremove --purge cuda
sudo dpkg -i ./cuda-repo-ubuntu1604-8-0-local-ga2_8.0.61-1_amd64.deb
sudo apt-get update
sudo apt-get install cuda-8.0

Similar problem in Windows. Do you know how can I uninstall CUDA 9.0 from Windows 10 Pro? The Add/Remove Programs (Apps&Features) doesn’t work.

When I click on “Uninstall” button and confirm, I’m asked to approve changes to my device (Rundll32.exe) and nothing else happens.

I facing the same problem as ntsarb. I’m trying to uninstall cuda 9, using Programs and Features widget in control Panel. After uninstalling it, i tried to install cuda 9 again, but it tells me that CUBLAS Development and CUBLAS Runtime are installed.

Please some help!!

Thanks

Same issue here with Win10 Cuda 9.1 Uninstallation…
Waiting for a solution from NVIDIA team.

:O

I always get:

sudo apt-get install cuda-8-0
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
cuda-8-0 : Depends: cuda-toolkit-8-0 (>= 8.0.61) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.