Download and install CUDA 8.0 instead of CUDA 9.0

I have a laptop with the following specs:

Intel i7-7700HQ
GTX-1050ti 4GB (mobile)
8GB ram

Running Ubutu 16.04.

I want to use Tensorflow with GPU. I installed the latest nvidia drivers (384), CUDA 9.0 and cuDNN 7.1 and Tensorflow (with GPU).

When I use python and import tensorflow, i have this error:

ImportError: libcusolver.so.8.0: cannot open shared object file: No such file or directory

I tried a new installation and the same has happened.

I think the problem is that tensorflow is trying to get the libcusolver.so.8.0 file, but since I installed CUDA 9.0, only libcusolver.so.9.0 is avaliable.

My question is very simple, how can I download CUDA 8.0? I think everything would work out alright.

When I go to this site:

https://developer.nvidia.com/cuda-downloads?target_os=Linux&target_arch=x86_64&target_distro=Ubuntu&target_version=1604&target_type=deblocal

the only option is downloading CUDA 9.0.

Thank you in advance!

scroll to the bottom of the page you linked, and click on “Legacy Releases”

That’s it!

Sorry for not responding earlier, I was checking if I had any other problem (and still am).

I have the same problem and I found this link https://devtalk.nvidia.com/default/topic/1024342/cuda-setup-and-installation/unable-to-uninstall-cuda-9-0-completely-and-install-8-0-instead/

uninstall the old one(9.0) and install cuda 8.0

here you can get all earlier releases :

https://developer.nvidia.com/cuda-toolkit-archive
Good luck!

Thank you!

I think it is working nicely now.

Just one thing, I have one desktop with a very nice i7 CPU (altough a few years old), and it takes about 25 milliseconds to forward an image (using Alexnet).

With my new laptop, which has 1050Ti, it takes 13 milliseconds. Is it normal to take that amount of time? I thought my new laptop would be able to forward an image 20x faster with the GPU. I’m thinking maybe I did something wrong and the laptop is actually using the CPU. How can I be sure?

EDIT: I read in a forum to use this:

sess = tf.Session(config=tf.ConfigProto(log_device_placement=True))

Which presents the following result:

2017-10-01 19:28:51.244911: I tensorflow/core/common_runtime/gpu/gpu_device.cc:1045] Creating TensorFlow device (/gpu:0) -> (device: 0, name: GeForce GTX 1050 Ti, pci bus id: 0000:01:00.0)
Device mapping:
/job:localhost/replica:0/task:0/gpu:0 -> device: 0, name: GeForce GTX 1050 Ti, pci bus id: 0000:01:00.0
2017-10-01 19:28:51.245333: I tensorflow/core/common_runtime/direct_session.cc:300] Device mapping:
/job:localhost/replica:0/task:0/gpu:0 -> device: 0, name: GeForce GTX 1050 Ti, pci bus id: 0000:01:00.0

Does this mean it is using the GPU? It seems so but is just so much slower than I thought it would be.

I had the misfortune of automatically updating and having Nvidia repo so I switch from 8 to 9…dangit now I gotta downgrade.

Newbie here and hit the same problem. Going with 8.0

pedro,

For doing the forward pass on the GPU, data has to be given to the GPU first, which could take a lot of time compared to the forward passing. But in case you do also backprop, and you give a mini-batch to your GPU instead of just one input data, you could get pretty nice accerlerations. So the GPU shines when it has to do the learning phase.

Hi Pedro,

I just want to make sure that moving from CUDA 9.0 to 8.0 solve your problem?

Thanks

Hi I converted from 9 to 8 and got this when running caffe make

Makefile:594: recipe for target ‘.build_release/cuda/src/caffe/layers/cudnn_lcn_layer.o’ failed
make: *** [.build_release/cuda/src/caffe/layers/cudnn_lcn_layer.o] Error 1
make: *** Waiting for unfinished jobs…

Go to http://www.python36.com/install-tensorflow141-gpu/ for step by step installation of tensorflow with cuda 9.1 and cudnn7.05 on ubuntu.

I am unable to download Cuda 8.0 toolkit for Windows-10, by the following link

I tried both network install and local-exe, in both the cases it couldn’t download the file.

Where can I find Cuda 8.0 toolkit?

Problem with CUDA Toolkit 9.0 download (Since 13Feb 2018)
I am trying to download it and I have tried almost 10 to 12 times using several explorers(firefox, googlechrome, E explorer) and even from my friend’s home using different ip address and even from different internet connection.

Each times it expires before my download is completed.
today my download stops at 96% when it explorer showed 0B/s for several minutes and when i pause it and resume it, error pop ups that link is either expires or restores etc.

I need it for tensorflow.
I tried for windows10
https://developer.nvidia.com/cuda-90-download-archive?target_os=Windows&target_arch=x86_64&target_version=10&target_type=exelocal

Do you have enough space on your hard drive?

Yes, I do have space 250GB SSD and I have tried downloading cuda toolkit 9.1 and it was successfully downloaded. But unfortunately 9.1 is not supported by tensorflow so I need 9.0 instead.
I download Cuda toolkit 9.0 for ubuntu 16.04 and even that is successfully downloaded. I dont know what is so special about cuda toolkit 9.0 for Windows 10.???

Hi. I installed CUDA 9.0 SDK, which installed a device driver that causes instability on my system. I used DDU to uninstall the driver and install a known-to-be-good NVIDIA driver, but I can not uninstall CUDA 9.0 using Add/Remove Programs (Windows 10 Pro). When I click on the “Remove” button and confirm, I’m asked to approve changes to my computer and nothing happens.

Any ideas on how to clean my system from CUDA 9.0 SDK without reinstalling Windows and reconfiguring everything from the beginning? I’ve got lots of software on the machine, shared printers, shared storage, etc, and I’d very much prefer not reinstalling everything.