CUDA Toolkit Version 9.1 not compatible with hardware

I am trying to install CUDA tookit version 9.1 to run Tensorflow on my Titan V gpu.

I first did a clean install of the NVIDIA Titan V driver. After doing so, I tried to run tensorflow. But i was getting this error:

ImportError: Could not find 'cudart64_90.dll'. TensorFlow requires that this DLL be installed in a directory that is named in your %PATH% environment variable. Download and install CUDA 9.0 from this URL: https://developer.nvidia.com/cuda-toolkit

I tried cuda_9.1.85_win10 toolkit download, but upon running it I got this error for System Check:

This graphics driver could not find compatible graphics hardware. You may continue installation, but you may not be able to run CUDA applications with this driver. This may occur with graphics hardware that is newer than this toolkit. In that case, it is suggested that you keep your existing driver and install the remaining portions of the CUDA toolkit

I was told that cuda9.1 is the toolkit that is compatible with Titan V. That is why I am trying to download this tookit.

Why is the toolkit not compatible with the hardware even after performing a clean install of the Titan V driver? Is there any way to run Tensorflow 1.8 with GPU support without this toolkit?

I ran into the same issue yesterday. For me I was able to install CUDA by using the advanced install option, and unchecking the driver, phsyx, and Visual Studio integration options.

Are you using your GPU for Tensorflow? If so, were you able to run Tensorflow after installing CUDA 9.1?

I’m able to run Tensorflow on my Titan V, but I think it’s using CUDA 9.0 instead of 9.1.

If you have a new enough GPU, the bundled driver with the CUDA toolkit installer won’t recognize it. In that case, keep the driver you already have (if you already have one) or else install it separately. Then install the CUDA toolkit while deselecting the option to install the driver.

Tensorflow binaries require a specific version of CUDA. Many of them are compiled to use CUDA 9.0. If you try to use CUDA 9.1 instead, it won’t work. You must install CUDA 9.0 (in that case).

I am trying to install cuda using the cuda_9.0.176_win10 toolkit download. However, I am getting the same error as above, but I continue and Agree to the license agreement. I select Custom (Advanced) and deselect Driver components. I have CUDA and Other components selected.

However, when I do this, I get the result: NVIDIA Installer failed and the CUDA/9.0/ folder is empty

I was able to successfully download CUDA 9.0. However, in the folder NVIDIA GPU Computing Toolkit/CUDA/v9.0, I cannot find the file cudart64_90.dll. I can only see cublas64_90.dll in the bin folder.

Where can I find the file cudart64_90.dll

On my computer it’s in the bin folder (NVIDIA GPU Computing Toolkit/CUDA/v9.0/bin).
2018-05-06_9-35-02.png

When i tried to download the CUDA 9.0 toolkit after deselecting the Driver components, these are the contents of my CUDA 90 folder as shown in the image below

https://snag.gy/JwCktd.jpg

@larkinan what driver version are you using for titan V

I’m currently using driver 397.64. In your snapshot, are those the only files in your bin folder? If so then CUDA 9.0 might not be installing properly on your machine. Are you sure you’re installing the 9.0 toolkit and not the optional add-on cublass library? On my machine cuda always installs essential executables such as the fat binary and cuda compiler in the bin directory. Cublass is a specific library for fast matrix operations.