(SOLVED)cudart64_90.dll not installed when installing CUDA 9.0

Hi!

So I’m trying to get tensorflow up and running on my windows machine. And I’ve noticed that after I install the CUDA toolkit I’m still missing some required DLLs like cudart64_90.dll. I really need to get Keras and TF up and running for work and I’m stuck right now. Please does anyone have any ideas to what I can do?

You’ll need to pay attention carefully to what is happening during the CUDA toolkit install. cudart64_90 should definitely be installed if you installed CUDA 9.0

(If you installed CUDA 9.1, you will not get that DLL, you’ll get something like cudart64_91 instead.)

I have. it’s not installed. It’s really weird i’ve tried reinstalling and the installation goes through without any problems but in my bin folder I only have 2 DLL files. I didn’t install 9.1 but 9.0 I’ve double checked and all.

Those libraries are not in the bin folder. Please do a windows search on your entire hard drive for that file.

after you installed CUDA 9.0, did you attempt to verify the installation? The verification instructions are in the windows install guide.

I can’t find them anywhere on my harddrive. No I didn’t verify the install I’ll do that and check back!

My mistake. They should be in the bin folder. Since they are not there (or anywhere) your install is broken.

I don’t think verification will work, although it might shed light on what the problem is/was.

You can also inspect the installer log. There are instructions to do so elsewhere on this forum if you look for them.

Cool, I’m trying to install via the network installer now maybe that will work. It’s weird tho cause I don’t get any error messages when installing and I tried two different installers. And it’s on a brand new computer…

Solved this by using the network installer.

Facing the similar issue. I’m not able to solve even using network installer. Could you please assist me?

The dll available under bin folder is “cudart64_7.dll”

I am having the same issue as gana619. I think the installer should do some extra cleaning before proceeding with the new installation. I mean, in my case the installer insert only “cudart64_7.dll” even though I used to select Windows10 during the download. In fact I have tried the network install and the local install. None of those install the “cudart64_90.dll”. I have drivers installed before installing those libraries. I have GTEForce 1070 on Alienware

Does the installer start again after rebooting? This is what was wrong with my local installer it would prompt me to reboot then it wouldn’t start up again after the reboot to finish the install.

I’m having the same issue, tried different installers and it’s still persisting. I have windows 10

I am having the same issue. I tried all the above steps and still the same error shows up. I have Windows 10, x86, corei7, GTX 960M machine. Also installed Anaconda for using Python Jupyter notebook.

ImportError: Could not find ‘cudart64_90.dll’. TensorFlow requires that this DLL be installed in a directory that is named in your %PATH% environment variable. Download and install CUDA 9.0 from this URL: https://developer.nvidia.com/cuda-toolkit

If any one have an updated link with solve, please share.

Hey! I have the same problem as you, Did you find some solution for this? where you able to made any progress?

thank you for your time :)

No I still haven’t found a solution to this. I tried unistalling and re-installing everything, went through the process of updating path, then updated CUDNN files in the CUDA installation. Still the same issue persists.

If you open the installer page there are three installers: “Base Installer”, “Patch 1” and “Patch 2”. Make sure that you run the base installer first–even though the patch installers look like they’re installing CUDA Runtime, I don’t think they actually include the whole thing.

Ladies and Gents

I know this is marked as solved but have an additional comment.
I had a similar problem. The need libraries had been installed but could not be found. I added the files to the %PATH% explicitly and it worked. Not sure why that resolved it.
Still some issues but on to the next issue.

ts1776

This item has been completely resolved. Tensorflow and Keras are working for me now.

I uninstalled Anacondas and Nvidia CUDA. Then I downloaded and installed CUDA 9.0 and its patches.

Installed Anacondas again. Followed instructions https://www.tensorflow.org/install/install_windows

Activated Tensorflow environment and Installed pandas, numpy, matplotlib, Keras, scipy, sklearn etc. Then open jupyter notebook from the anaconda prompt.

I had the same problem.

For me (Surface Book 2, NVIDIA GeForce GTX 1060), the problem was resolved after:

  1. full uninstallation of CUDA Toolkit 9.0 installed using exe(network)
  2. installation of CUDA Toolkit 9.0 using exe(local)

For some reasons, exe(network) did not download DLL needed for TF.