Could not load dynamic library 'cudart64_100.dll'; dlerror: cudart64_100.dll not found for cuda_10.1.243_426.00

Could not load dynamic library ‘cudart64_100.dll’; dlerror: cudart64_100.dll not found

getting the above error while importing TensorFlow. I have cuda_10.1.243_426.00 and cudnn v7.6.4.38_18-28-51.

tried adding cudart64_100.dll and tried training models. Now I am getting an error while fitting the model.

thanks for the help in advance.

you need to install cuda 10.0, then it works

I have the same issue as the OP. I also had CUDA 10.1, but after downgrading CUDA and reinstalling the compatible CUDNN per the instructions, I still get the same error.

CUDA Version 10.0.130

The DLL exists in the expected location.

(tf) C:\>dir /b "C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\bin\cudart*"

(tf) C:\>set | findstr /i cuda
CUDA_PATH=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0
CUDA_PATH_V10_0=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0
NVCUDASAMPLES10_0_ROOT=C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0
NVCUDASAMPLES_ROOT=C:\ProgramData\NVIDIA Corporation\CUDA Samples\v10.0
Path=C:\Users\Paul\Miniconda3\envs\tf;C:\Users\Paul\Miniconda3\envs\tf\Library\mingw-w64\bin;C:\Users\Paul\Miniconda3\envs\tf\Library\usr\bin;C:\Users\Paul\Miniconda3\envs\tf\Library\bin;C:\Users\Paul\Miniconda3\envs\tf\Scripts;C:\Users\Paul\Miniconda3\envs\tf\bin;C:\Users\Paul\Miniconda3\condabin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\bin;C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.0\libnvvp;...

de Lujo, con ese archivo sí funciona, gracias!

The latest TensorFlow versions (2.0 and 1.15) are still using CUDA 10.0. Why TensorFlow containers starting from 19.03 use CUDA 10.1?

The NGC containers contain the latest toolkit and nvidia libraries, like cudnn and nccl. Upstream TF chooses to update CUDA dependencies less frequently.

I had the same issues where downgrading and updating path did not help. However running import again after the error ran fine.