RTX 3070, CUDA 11.1, CUDADNN 8.05 and Tensorflow

Dear all,

I have encountered a problem when I tried to install tensorflow-gpu in my anaconda environment.
When I tested the availability of GPU after import of tensorflow, it seems that a dll library (cudasolver64_10.dll, provided normally with CUDA package) is missing and the test failed.

From Google, I saw that some guys copied from previous version of CUDA (eg CUDA 10.2, the dll and pasted it on the right folder). Is it the right thing to do? Should I try to compile Tensorflow by hands?

CUDA and CUDA DNN installed from Nvidia documentation and tests succeeded (regarding samples from CUDA folders).

CUDA 11.1
CUDA DNN 8.05
Windows 10 Home
Visual Studio Community 2019
Framework: Anaconda, virtual environment created with python 3.8, installation of tensorflow from pip tf-nightly-gpu (le latest dev package from 20201210)
Ryzen 3900XT
RTX 3070

Thank you for your answer.
Best,
Enrico

Hi @perspi_eric057

According to the Anaconda documentation, the version 11.1 of CUDA is not supported by the current built of TensorFlow 2.0 (using tensorflow-gpu). You can play with that trick but it may lead to more errors which can be even more messy.

If you want to have an isolated environment to develop and avoiding installing the TensorFlow on your system, you can play with the NVIDIA containers for WSL:

Best regards,
Leon.

Hi Leon,

Thank you for your reply and for the trick concerning WSL. It’s a good idea indeed.
Yesterday, I installed CUDA 11.0 and cuDNN 8.0.4 instead of CUDA 11.1 and cuDNN 8.0.5.

I made some tests and all passed.
I tried also my code and it seems to work.
I had just needed to set the parameter for memory growth before loading Tensorflow because I got OOM message error…

Best regards,

Enrico

1 Like