Help appreciated: Trouble setting up CUDA 10.0 on Windows 10 Pro (RTX3090)

Hello all, I’m in need of some advice. I set up my first GPU for my DL rig with the RTX 3090 GPU.

My goal was the run a Mask RCNN model using code form this link: matterport/Mask_RCNN: Mask R-CNN for object detection and instance segmentation on Keras and TensorFlow ( The program is old and uses tensorflow-gpu 1.14 and keras 2.2.4 with CUDA 10.

The issue is that on the RTX 3090 computer it cannot install CUDA 10 causing the code to fail saying it needs CUDA 10 installed.

What I’ve tried

  • I have tried installing CUDA 11.0, cudnn 8.0.4 and upgrading to tensorflow-gpu 1.15. The code runs but since it can’t open files from CUDA 10 it runs on CPU instead. This takes hours to finish running
  • There was supposedly an updated version of the code ( leekunhee/Mask_RCNN: Mask R-CNN modified to run on TensorFlow 2 ( which uses tensorflow 2.3.0, keras 2.4.3, cuda 11.1 cudnn 8.1. I installed everything as instructed but the same thing happens where its asking for CUDA 10 files.
  • I took the older dll CUDA 10 files and put them into the CUDA 11.1 and CUDA 11 bin folder but the program keeps asking for files and eventually asks for files that don’t exist.

All that I’m asking for is to have my code run on the computer’s GPU. CUDA 11 is obviously having some issues so is there some solution to get CUDA 10 installed? If nothing is possible can someone recommend a GPU that’s at least 12GB which is compatible with CUDA 10.

Any advice is greatly appreciated, thank you for your time.

RTX 3090 uses the Ampere GPU architecture. CUDA 11.0 is the oldest CUDA version that supports this architecture. The current CUDA version is 11.2.1.

I don’t use the middleware components you mention. Often there is some delay until software layered on top of CUDA supports new CUDA versions. From what I can find, Tensorflow and Keras have in fact been updated to support CUDA 11 amd Ampere:

So it looks like your issue may come down to an incompatibility with Mask RCNN? You may want to contact the vendor / author about this.

Thank you very much for replying to my question.

While looking at solutions someone updated the code to work with tensorflow 2.#. The code still had issues since it kept asking for CUDA 10 dll files. I’ve placed the files it asked for in the CUDA 11.# bin folder but it kept asking for files until it asked for one which didn’t exist. Do you have any thoughts?

Thanks for your time.

Find out which code is asking for these files. CUDA releases are self-contained, so CUDA 11 is not dependent on files from CUDA 10. It is also possible to keep multiple CUDA versions on one machine, I have had up to four on my systems.

If you cannot find out which software component is asking for the CUDA 10 files, I would suggest carefully purging the entire software stack involved from your system, then follow that with clean install, one layer at the time, with testing at each layer to make sure things work.

So start with CUDA at the bottom of the software stack. Run some some sample apps that ship with it to ensure it works. If so, install the next layer, looks like that would be CUDNN. Run a simple CUDNN example to make sure that works. Rinse and repeat until all the software is in place.