Problem with CUDA 10 and Tensorflow 1.11

Hello,

I have Windows 10 , a Geforce 1060 6GB and I have installed CUDA 10. What I would like is to use tensorflow gpu for deep learning purposes. I have installed tensorflow-gpu 1.11

I installed some C++ compilers in Microsoft Visual basic 2017 prior to CUDA 10 installation.
I tried CUDA which was compatible with the graphic card but not CUDA 9.
Then , I copied the cudnn 7.3.1 (latest) .dll into the bin located in CUDA/bin.

Problem is…tensorflow doesn’t still recognize my GPU (recognize only the CPU but printed “CPU supports instructions that this TensorFlow binary was not compiled to use: AVX AVX2”).

Version of keras 2.2 are still not compatible with tensorflow 1.11.

I checked te version of CUDA and it worked ,it is the 10 version printed out.

However I tried the C++ compiling tests (I tried to compile the bandwidth project in Microsoft Visual Studio loacted in CUDA Samples ) but it seemed to fail.

Can someone help me please , I am a bit desperate !

I working with python 3 on ubuntu 18.4, so my answer may not apply to you. However, I don’t think the official tensorflow releases are compatible with CUDA 10, only CUDA 9. Some discussion here https://github.com/tensorflow/tensorflow/issues/21741.