Can't use any NVIDIA driver on Ubuntu 18.04 (4.15.0-39-generic)

No matter from what source I try to install the driver (or what version) I cannot get the nvidia-smi command to work, it only produces

ERROR: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver

My GPU is K1100M.

I’ve tried all the ways to install the driver that I could find, including the recommended instructions from https://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html. I’ve also searched these forums to try to find a solution, but to no avail.

I’ve attached the outputs of nvidia-bug-report.sh here: https://we.tl/t-GY30MFY5M9

  • NVIDIA-Linux-x86_64-340.107.run gives and incompatible pointer error when running dkms
  • NVIDIA-Linux-x86_64-390.87.run gives ERROR: Unable to load the 'nvidia-drm' kernel module.
  • Version 410 and 390 from the nvidia repo (see also attached bug report) produces ERROR: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver
  • Version 390, 410 and 415 from the graphics ppa repo (see also attached bug report) produces ERROR: NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver

Please help me to get any driver working, preferably one that I can use with cuda 9.0.

Thanks

Now that’s a mess, don’t know if reinstalling would be faster, but try this:
Delete the following files (as root)

/usr/share/X11/xorg.conf.d/20-intel.conf
/etc/X11/xorg.conf
/var/log/Xorg.*

Then uninstall the .run installer using the --uninstall option. Never use that .run installer again, since your notebook is an Optimus system the .run installer does not work for that.
Reinstall the 410 or 415 driver from ppa.
Install the package nvidia-prime

sudo apt install nvidia-prime

Afterwards, run

sudo prime-select nvidia

Then run

grep blacklist /etc/modprobe.d/*

and

grep blacklist /lib/modprobe.d/*

to find any file that is stating something like

blacklist nvidia ...

and remove that file.
reboot, if it still does not work, create a new nvidia-bug-report.log and attach that, see:
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

If the driver is working, the install instructions for cuda are

  • download the cuda .deb
  • add it to your system
  • don’t install cuda
  • instead, run sudo apt install cuda-toolkit-10-0

Thank you so much for your help, it worked perfectly!

user@ubuntu-18.04:~$ sudo rm /usr/share/X11/xorg.conf.d/20-intel.conf
user@ubuntu-18.04:~$ sudo rm /etc/X11/xorg.conf
user@ubuntu-18.04:~$ sudo rm /var/log/Xorg.*

user@ubuntu-18.04:~$ sudo ./NVIDIA-Linux-x86_64-390.87.run --uninstall
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 390.87.........................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
user@ubuntu-18.04:~$ sudo ./NVIDIA-Linux-x86_64-410.78.run --uninstall
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 410.78...................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
user@ubuntu-18.04:~$ sudo ./NVIDIA-Linux-x86_64-415.18.run --uninstall
Verifying archive integrity... OK
Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 415.18.............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

user@ubuntu-18.04:~$ sudo apt install nvidia-prime
Reading package lists... Done
Building dependency tree       
Reading state information... Done
nvidia-prime is already the newest version (0.8.8.2).
nvidia-prime set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
user@ubuntu-18.04:~$ sudo prime-select nvidia
Info: the nvidia profile is already set

user@ubuntu-18.04:~$ grep blacklist /etc/modprobe.d/* | grep nvidia
/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/etc/modprobe.d/nvidia-installer-disable-nouveau.conf:blacklist nouveau
user@ubuntu-18.04:~$ sudo rm /etc/modprobe.d/blacklist-framebuffer.conf
user@ubuntu-18.04:~$ sudo rm /etc/modprobe.d/nvidia-installer-disable-nouveau.conf
user@ubuntu-18.04:~$ grep blacklist /lib/modprobe.d/* | grep nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-modeset
/lib/modprobe.d/nvidia-graphics-drivers.conf:blacklist nouveau
/lib/modprobe.d/nvidia-graphics-drivers.conf:blacklist lbm-nouveau
user@ubuntu-18.04:~$ sudo rm /lib/modprobe.d/blacklist-nvidia.conf
user@ubuntu-18.04:~$ sudo rm /lib/modprobe.d/nvidia-graphics-drivers.conf

user@ubuntu-18.04:~$ sudo reboot

user@ubuntu-18.04:~$ nvidia-smi
Mon Nov 26 19:00:38 2018       
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 410.78       Driver Version: 410.78       CUDA Version: 10.0     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  Quadro K1100M       Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   48C    P0    N/A /  N/A |    198MiB /  1999MiB |      2%      Default |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1618      G   /usr/lib/xorg/Xorg                           103MiB |
|    0      2130      G                                                 12MiB |
|    0      2392      G   /usr/bin/gnome-shell                          77MiB |
+-----------------------------------------------------------------------------+

You deleted a bit too much, please recreate the following files with contents:
/etc/modprobe.d/blacklist-framebuffer.conf

blacklist nvidiafb

/lib/modprobe.d/nvidia-graphics-drivers.conf

blacklist nouveau
blacklist lbm-nouveau

and run
sudo update-initramfs -u
afterwards.

I notice same problems with newest kernel in Ubuntu 18.10. I changed back to previous version and black screen of death problem is solved.

$ uname -a
Linux delllap-16 4.18.0-10-generic #11-Ubuntu SMP Thu Oct 11 15:13:55 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

I’m suggesting this is not a video problem as much as a kernel update problem. Wrote about it in askununtu.

Before you chase your tail with display issues, try the older kernel.

thanks you very much erikwouters64 :) I spent four days for this problem :)