Capture-camera does not work

ood, and I’ve been seeing the example of jetson-inference and now that I’m going to do the data collection to train my own model the capture-camera application didn’t work

solver@solver-desktop:~/jetson-inference/tools/camera-capture$ camera-capture --camera = / dev / video0 --width = 640 --height = 480
bash: camera-capture: orden no encontrada

Hi candanoza, did you select PyTorch to be installed during the build process? That installs a dependency that is required by this program, otherwise it won’t be built.

Also please try running the app from jetson-inference/build/aarch64/bin

yes, I installed the pytorch in the 2 versions of python and also probe run from jetson-inference / build / aarch64 / bin

It looks like you have extra spaces in your command line. For example, above it shows:

--camera = / dev / video0 --width = 640 --height = 480

There shouldn’t be extra spaces:

--camera=/dev/video0 --width=640 --height=480

They are without spaces, only that at the time of translation separates them. And if it were that, I should say that there is a syntax error or something like that, right?

wait I do not understand you well, I did not install pytorch during construction if not lurgo should I build it again?

another question, to install the DIGITS the host machine must have an NVIDIA gpu?

Yes that is correct, DIGITS training server or PC should have an NVIDIA GPU.

Instead of fully installing pytorch, you can install “qtbase5-dev” package and re-building:

$ sudo apt-get install qtbase5-dev
$ cd jetson-inference/build
$ cmake ../
$ make

The camera-capture app should then be built.

Ok this worked for me, thank you very much for your help friend

Friend one more question, as far as I understand the jetson_clocks command increases the performance of the jetson nano, until there everything is fine, but when I execute it I don’t notice its performance increase. So I don’t know if there is any way to see if I really increase its performance. I don’t know if this is relevant but I feed the jetson with the 5v 4a barrel connector

Hi Dusty,
I have some troubles to run the camera-capture tool with the .cpp file due to QtWidgets from the line #include :

wm@wm-desktop:~/jetson-inference/tools/camera-capture$ g++ camera-capture.cpp
In file included from camera-capture.cpp:24:0:
controlWindow.h:26:10: fatal error: QtWidgets: No such file or directory
#include
^~~~~~~~~~~
compilation terminated.

I tried many ways to install QtWidgets module but unsuccessful, I installed PyTorch as well.
If you could help me, thank you.

If your Nano is in 10W mode (MAX-N) and you ran jetson_clocks, then that would maximize performance.

It looks like you are manually trying to compile the tool with g++. You would need to specify all the additional include and linker directories. Instead, please refer to the CMakeLists.txt file. The project will automatically compile it from your /build dir.

I have some trouble like @candanoza and your solution doesn’t work. Any idea?

Hi ionut, can you tell if the camera-capture app is building when you run make, or what is the trouble you are having?

Can you post the terminal output of when you run ‘cmake …/’ command and also ‘make’ command?

It’s work. Thanks!

Hi,dusty! my camera-capture app is camera-capture.cpp .Is it true?When I used terminal ,it displayed (bash:camera-capture:command not found).I don’t know what is wrong?
I followed this website:https://github.com/dusty-nv/jetson-inference/blob/master/docs/pytorch-collect.md



Hi andy8902,

Please file a new topic for your issue.

Hi,duty! I just try a newest Object Detection (SSD-Mobilenet) of jetson-inference. I try Re-training object detection, it’s work for me base on OpenImages. but when I try to Collecting my own Detection Datasets with Camera-capture then go to train my own object ,it’s didn’t work. I look dataset on OpenImages with Camera-capture it 's not the same, So I must make my dataset like OpenImages I download right ? How to solve and collection my own dataset training ?