Challenges of vGPU Utilisation monitoring

A Short video to show what happens when you try and monitor vGPU utilisation with Perfmon inside a VM, and an alternative option.

Just in case you’ve ever just assumed the GPU’s not being used…

Hi Jason,

When i monitor the vGPU with TechPowerUp GPU-Z the "GPU Core Clock" and the "GPU Memory Clock" stays at 0. All the processing is done by the CPU instead of vGPU. I experienced a poor performance.

Xenserver 6.5
Xendesktop 7.6
Windows 8.1 VM
16GB Memory
4 vCPU
Grid K2 K240Q
Driver 340.78-341.44


You’re showing 60% utilisation on the GPU, so the GPU is being utilised. The clock WMI metric’s look like they’re not being reported in 8.1 and GPU load is read directly from the GPU in GPU-Z not via WMI.

What "poor performance" are you experiencing?
Where are you measuring perfromance and how are you measuring it?

Thanks for your reply. In AutoCAD the mouse is lagging and slow.
Zooming of Adobe CS6 is slow and stuttering.
When I run the Heaven Benchmark it runs at 55fps but it looks like it runs at 6fps

The result in Windows 7 is the same.
When I give more CPU cores to the VM the performance is a little bit better. But not acceptable

Those are all issues incurred with the remoting protocol.

If you’re running XenDesktop, take a look at the suggested HDX policy I posted in this forum and the Citrix one.

Also, ensure you’ve got a sufficiently capable client for the decoding of the HDX connection.

I’m having the exact same problem using vGPU VMware 6.0 View 6.1, the server I’m using is a new R730 with 192 GB of memory, Teradici Apex 2800, 2 TB of SSD’s and SD flash for the VMware OS, I have 12 VM’s running Windows 7 enterprise and nothing seems to be stressed except mouse and keyboard seem to be delayed even went connected on the LAN. Everything seems fine I’m using the 140 profile which is a 1GB of vGPU memory and the apps are REVIT 2015. End users are using the latest View client from VMware on their highend Dell Precision workstations. We have bypassed the riverbeds, turned off traffic shaping on Cisco and still no luck as tio why the mouse and Keyboard would have a delay of a half second or so seems to change anyway any suggestions or help would be appreciated.


Welcome to my world, CTOVDP. We have a very similar setup and have some similar steps to isolate and troubleshoot. The behavior your describing is usually packet loss over PCOIP protocol. It is easy to prove, just switch a pool to RDP and see if the performance change is dramatic for typing and clicking.

I’d suggest opening a specific thread as the discussion for mouse delay you have here is buried in my thread for performance monitoring and they’re unrelated.