Autocad/Revit slow performance

Hello

We have set up a PoC with 2x nvidia grid 2k/xenserver 6.2/xendesktop 7.5 but the performance in Autocad and Revit 2014 is really slow.

Dell R720, 8 300gb SSD raid 10, enabled turbo mode, disabled console to vms.

The vm specs are
8 core
16gb ram
GRID k260Q

I’ve tried 4/16 cores, more ram and k240Q

HDX3D Pro enabled

If i run the uniegine benchmarks the results seems fine compared to others. But if i run Cadalyst performance the 3d performance is just abyssmal if i look at other results.
Even installed a game Dota2, and got decent fps 60.

In Revit as soon as i hit the 3d views and its somewhat complex rotating the model is painfully slow.

Tried gpu monitoring tools and they say that maybe 10% av the gpu is used when rotating(dunno if it checks the performance for vgpu or the physical card)

Desktop composition redirection is disabled thats about it with policies.
I have EnableWPFHook in the registry.

Any ideas?

Config looks fine, but what CPU’s in the physical server?

CPU Speed can affect performance dramatically as both AutoCAD and Revit are single threaded and very CPU intensive. We’ve seen PoC’s where CPU speed has been the bottleneck.

In order to get AutoCAD 2014 running with vGPU, you need to update the AdskHwCertificationDatabase.xml file, located at C:\Users\Public\Documents\AutoDesk\AutoCAD 2014\R19.1\PTXML, with the appropriate vGPU profile. So if you haven’t made this change, AutoCad will revert to CPU only.

You should confirm that hardware acceleration is enabled in both AutoCad and Revit.

Hi thanks for your input, i have thought about the speed also.

Its 2 Xeon E5-2660 2.2 ghz, any experience with that one?

I’ve been to the customer today and looked at the performance difference between local and Xendesktop and it actually was only abit fast on their Pcs in Revit.
They also had a consultant from their Cad supplier there and he said that they work slightly wrong, loading the full models instead of only relevant parts.

I will try the AutoCad thing

CPU speed is a little on the low side.
The fact that the workstation is only marginally quicker is interesting.

Have them check the settings for hardware virtualisation in the VM, because if that’s off, it’s not going to use the GPU at all…

There’s another thread in here on Autocad 2014 settings

https://gridforums.nvidia.com/default/topic/293/autocad-2014-registry-tweak-turns-on-hw-acceleration/

Yes only slightly more delay for them. Their Cad consultant support also said that it was almost impossible to get their models completely smooth in 3d view with any computer.

Uhm hardware virtualisation in the vm? i see the option in vsphere but not in xencenter.
Hardware virtualisation is enabled in bios.

But i see activity on the gpu with external tools and nvidia-smi command in xenserver.
Even tho it doesnt seems like much, less then 10% while rotating a 3d model in revit.

I ran the Uniengine directx11 test also and it seemed to score decent so the gpu should work

In the application settings (for Revit & AutoCAD) inside the VM. Not on the VM iteself. If the applications aren’t configured to use hardware acceleration, they’re going to render on the CPU.

It looks as though you’ve made some progress in the application usage pattern to improve perfromance though having seen this thread here:

http://discussions.citrix.com/topic/355362-poor-performance-xd7-grid-k2/

Linking them together so that other’s can benefit from your findings too.

Yes the applications use hardware acceleration.

Right now im pretty satisfied with how the environment works. Customer is happy with the performance.

Next setup we will go with the faster CPU and see if it works even better

Thanks

Great, let us know how you get on with the faster CPU’s.