Xenserver 6.5 with K2 on Dell R730

Hi,

We are currently setting this up and met some trouble with the VGPU profiles in VMs. XenServer 6.5 is installed, we are currently building master image on Win 7 SP1. VGA standar adapter is disabled and NVidia 341.08 is installed on the Windows. Windows does see the NVIDIA control panel and the see the VGPU profile that have been provided.

The problem is when we are running Autodesk REVIT, the program doesn´t see the VGPU and therefore when we choose renderingen we can´t seem to see the VGPU monitor is working at all. CPU on the host does goes really high up. So we are mistaking that the VM are using the CPU instead of VGPU for renderingen. We have tried to give the VM differents profiles and tested this out but the problem is the same. We did also tried with BLENDER to verify if it is Autodesk is the problem. Under Blender options under COMPUTE DEVICE we can only see CPU. So therefore i think there must something wrong with the setup that we did.

From XenCenter and within the VMs we can se the VGPU profile all the way, the settings seems to be correct and the VMs does the the VGPU control panel too. Any idees to solve this? Much appricated!

If nvidia-smi run on your XenServer isn’t showing any activity, no matter what you run, there is likely an issue with the installation of the driver on the VM. Can you run the NVIDIA configuration application on the VM itself and verify you can check/change any of the settings?
Also, do you have the right XenServer license required installed? See: https://gridforums.nvidia.com/default/topic/387/xendesktop-with-nvidia-grid/xs-6-5-and-vgpu-not-seeing-vgpu-profiles-in-console/

If the license were wrong I’d expect War to have been unable to select a vGPU in the VM properties.

Check the video below for basic configuration checks.

https://www.youtube.com/channel/UC-uILPo9BZDMjBXUVZQoVgw

Also, ensure you’ve got hardware acceleration turned on in Revit.

Make sure you’ve selected a vGPU profile that’s adequate for the application. In some instances if you have too little Graphics Memory assigned the application doesn’t enable acceleration.

As for Blender, it requires CUDA, so you’d need to use GPU passthrough with the appropriate driver before acceleration will be enabled.

Hi,

Sorry for the late response. I have follow the check configuration on youtube and saw somehitng weird. When i run DXDIAG, the VM can see all 3 options in directX enable. But when I open Nvidia Control panel
I was missing the PhysX configuration under 3D settings, with this I can’t seem to see the CUDA options either under GLOBAL SETTINGS.

Here are screenshot of my NVIDIA-SMI:
[root@a20-p1-xen001 ~]# nvidia-smi
Fri Feb 6 11:00:32 2015
±-----------------------------------------------------+
| NVIDIA-SMI 340.57 Driver Version: 340.57 |
|-------------------------------±---------------------±---------------------+
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
|===============================+======================+======================|
| 0 GRID K2 On | 0000:05:00.0 Off | Off |
| N/A 34C P8 27W / 117W | 2000MiB / 4095MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 1 GRID K2 On | 0000:06:00.0 Off | Off |
| N/A 33C P8 27W / 117W | 1869MiB / 4095MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 2 GRID K2 On | 0000:84:00.0 Off | Off |
| N/A 34C P8 28W / 117W | 12MiB / 4095MiB | 0% Default |
±------------------------------±---------------------±---------------------+
| 3 GRID K2 On | 0000:85:00.0 Off | Off |
| N/A 31C P8 27W / 117W | 12MiB / 4095MiB | 0% Default |
±------------------------------±---------------------±---------------------+

±----------------------------------------------------------------------------+
| Compute processes: GPU Memory |
| GPU PID Process name Usage |
|=============================================================================|
| 0 10719 /usr/lib64/xen/bin/vgpu 1856MiB |
±----------------------------------------------------------------------------+

Everything seems fine with the correct settings for vGPU, When we runed benchmark from NVIDIA UNIGINE Heaven, We can see the VGPU card working properlies. Even though in REVIT, the hardware accelation are active, Te program can’t seems to find the vgpu-profile. I also tried to give it VGPU pass through and intalled the drivere that REVIT require, but hen I can’t se the Performance TAB for the vGPU pass though card in XenCenter. Thanks again for your time!

That’s expected, CUDA and PhysX are only available with GPU passthrough configurations, not vGPU. So if you’re set up for vGPU you won’t see options for them in the Nvidia Control panel.

Also, I need to update that video as XenApp behaviour has changed when used with XenServer 6.5

Thanks Jason!

We have maid some discovery with the Autodesk applicationon Xenserver 6.5 with Nvidia driver 341.08.
Apperently as for today Autodesk doesn’t support for the graphic driver for 341.08 on Xenserver 6.5. Therefore we had a lot of trouble with installing and opened the application like AutoCAD. What a shame for us to wait for a updated driver version. In order to make this work on XenServer 6.5 we have to give it Pass Through GPU and installed older driver like 332.83 for Windows 7 and wait for the fix from Autodeks. We have already an open case with them on this, and are waiting for reply from them.