vGPU not showing up when creating VM's

Hello all,
I’ll try to be brief but thorough. I have a Cisco C240 server with 2 K2 cards installed. The following have been completed:

  • MMIO above 4GB = Disabled

  • XenServer 6.2 SP1 installed with updates 2-4 applied

  • vGPU manager is installed successfully

  • lsmod | grep nvidia output:
    nvidia 9656305 26
    i2c_core 20294 2 nvidia,i2c_i801

  • dmesg | grep NVIDIA output:
    [ 24.725601] nvidia: module license ‘NVIDIA’ taints kernel.
    [ 25.444933] NVRM: loading NVIDIA UNIX x86 Kernel Module 331.59 Thu Mar 13 10:40:07 PDT 2014

  • nvidia-smi output shows driver version 331.59, and all 4 GPU’s available

So far everything looks good according to the nVidia/XenServer guide that came with the vGPU mgr download. However, when I create a VM, I am not presented with any GPU options. After the VM is created, I can then edit the VM but the GPU type only allows me to select “NVIDIA GK104GL [GRID K2] GPU’s (4 GPU’s)” which appears to be simply a passthru.

I followed the guide verbatim, rebooting when necessary. I’ve also uninstalled/reinstalled vGPU mgr without success.

Running out of ideas. Have I missed anything? Not sure where to go from here. Any help is greatly appreciated!

Which version of Xencenter are you using?. I believe I remember seeing an issue like that with an outdated version. Latest version 6.2. Please let us know if that helps.

Thanks for that! I had downloaded the latest XenCenter (or so I thought). After poking around, I found a hotfix for XC for XS 62SP1. Uninstalled current XC, installed the new one, and now I am presented with the correct vGPU profiles. Download can be found here: http://support.citrix.com/article/CTX139790

Thanks for the help!