Getting driver error with k220q on Dell R720 with Nvidia Grid k2

I have had and issue with using vgpu on a grid k2 card. I have installed the latest nvidia vgpu driver. When I start up the machine in xencenter I get an error code 43 on the k220q in device manager. This is on a VM I created in xencenter with xenserver tools installed.

Did you build the VM with the newest library that incorporates the K220q configuration? The older one did not contain it.

So far this is what I have done

Get 720 from vender with xenserver prinstalled

Moved over nvidia grid vgpu package and install, NVIDIA-vgx-xenserver-6.2-331.59.01.i386.rpm

reboot host,

Now shows k220q as an option on creation of vm

create vm

Install VDA

Install xenseerver tools

install grid vgpu driver

Driver fails.

am I missing a step?

What version of XenServer are you running (I think you need at least 6.2 SP1)? Note you also will need with 331.59 the XS62ESP1004 hotfix (see CTX140417).

Does this work on any other formats or just not K220Q? Which VGPU software release from NVIDIA (needs to be 332 or greater, I believe)?

Hope this helps!

Vender said that it has 6.2 with sp1. Not sure on hotfix. the k240q format has had the same issue. Driver software is 332.83_grid_win8_win7_64bit_enlish.exe. I will look into the hot fix and see if that helps.

When I try the hotfix is says the update has already been installed.

Also changing the machine to k200 card results in a code 43.

Sounds like part of the installation didn’t go well. What hardware is this in? In Dell boxes, for example,you have to change a System BIOS setting to keep integrated devices from being mapped above the 4 GB mark.
I’d carefully review the installation guides at http://us.download.nvidia.com/Windows/Quadro_Certified/GRID/312.56/312.56-win7-grid-vgpu-release-notes.pdf and http://www.citrix.com/content/dam/citrix/en_us/documents/go/configuring-xenserver-to-use-nvidia-grid.pdf (which have since been replaced with newer version).

This is in a Dell R720. I did the Bios setting and am following the directions listed in the second document. I have gotten to the point where I am trying to check the nvidia control panel settings and since the driver is crashed I can’t. Reviewing the first pdf, I am getting the behavior described for #17 but have tried running the newest drivers I can download from the site on the vm.

Is your BIOS updated, as well, on your R720? I would also try reseating the K2 card and making sure all connections are good. Maybe something was flakey in the driver download, and it may be worth the effort to get a clean copy and re-install it.

This is my current bios information. Not sure if this is up to date.
BIOS Information
Vendor: Dell Inc.
Version: 2.2.2
Release Date: 01/16/2014
Address: 0xF0000
Runtime Size: 64 kB
ROM Size: 8192 kB

Tried multiple driver downloads to make sure the download was good.

Also, looked through var/log/messages to see if there are any errors using the vmiop_log. I am not seeing any. Only seeing an error related to SR pointing to a CIF ISO for my win7 and win8 images. I will try reseating the card in the morning (in EST). Thank you for all your help.

I managed to get it working. there must have been an issue with the rpm for the xenserver. I did a yum remove and reinstalled it, restarted the server, installed a updateded xencenter and it is now working. Thanks again for your help.

Aha! I have seen installs sometimes not “work” even if the install claimed it went OK, so I’m really glad you didn’t have to tear your server apart! Great to hear all is well now. :-) And, BTW, it’s always more than just a good idea to use at least the XenCenter equivalent or newer than the one that comes with the XenServer release. Things can change enough that older XenCenter versions are not fully compatible with newer XenServer versions.

Best regards, and glad to have been able to help,

Yeah. If we move forward with this then I will definitely keep that in mind (currently in a POC period). Now I just have to pull a all nighter to get my VMs up and stress test this bad boy with multiple point cloud extractions ;-). Thanks again.