K1/K2 Driver Upgrade Issue for XenServer 7.0


I’m testing out XenServer 7.0 using vgpu with a K1/K2 card setup. I installed the latest driver (361.45.09) from nvidia on the xenserver succesfully. The problem is when I create a win7 VM and install the corresponding driver (362.56), the VM will see the card it was given, but will say the driver stopped working so it doesn’t use the card. This is before xentools or xendesktop is installed. It’s acting as if the video driver is not compatible.

Any help on this would be greatly appreciated. Thanks!


Same issue here.

The setup:
Cisco B200 M4
Nvidia GRID Tesla M6
XenServer 7

We have tried:

  • different OS’s in the VM’s: Win7, Server 2012 R2, Win10, Server 2016 - all the same: Error code 43 in the Device Manager.
  • A couple of reinstallations of XenServer 7, only with the recommended patches (002 + 004)
  • Did a GPUmodeSwitch more than once and verified that the card is in Graphics Mode

We are about to install XenServer 6.5 SP1 with appropriate patches, as to see if XenServer 7 is the problem.

Will get back when I know more.

Reverting to XenServer 6.5 SP1 solved the issue. Tested and verified with Win10 and Win7 by GPU-z, Device Manager, Nvidia G-sync Pendulum demo.

I suspect this is a XenServer 7 issue, as different hardware-vendors and GRID-cards are affected.

I also posted this on Citrix forum - http://discussions.citrix.com/topic/380301-xs7-and-vgpu-display-adapter-error-code-43-in-vm/

FYI: Created a Citrix support ticket and Cisco TAC-request on it.

FYI: It seems that for my case, Cisco is releasing a new Firmware with support for vGPU in XenServer 7

Thanks for the update - useful to know - I don’t suppose you have a Cisco case reference so anyone else can raise it with frontline at Cisco easily?

Our issue with the K1 and K2 cards on a dell r730 with 786gb was resolved by disabling ioumm