Dell R720 with GRID K1 Card and XenDesktop 7.5

We are creating a site for our AGFA imaging systems, so that we can provide doctors the ability to access diagnostic quality imaging anytime, any place. First things first, I need to build the infrastructure. I’ve setup XenServer 6.2, fully patched. Setup my storage, built the controllers, setup Storefront Services 2.5, and I’ve even tried my hand at a VM. the VM works fine, and the app is functioning properly, but when I try to install the VDA, it tells me that there is a problem with the GPU. I have installed the drivers on my XenServer hosts, as well as installing the drivers on the VM (Windows 7 x64, 16GB RAM, 1 GPU, 125GB disk, 10gbe network). No luck at all.

Has anyone had success installing the VDA? Getting ready to call support, but I thought that I would ask on the various forums first.


Jim Dirkes

HAve you set the BIOS, there’s some advice and a setup video on

Also make sure you have the vGPU and not GRID drivers downloaded - loads of people made this mistake.

Make sure you set rwx permissions on the rpm file. After it installs you should be able to do a

lsmod | grep nvidia

If that doesn’t return anything try a toolstack restart, and it is still shows nothing you should check that mmio is disabled in bios as Rachel mentioned.

You can reinstall by doing:
rpm -qa | grep nvidia (Displays the package name)
rpm - e package name

Make sure that you installed all components inside the VM in the correct order

  1. Install latest NVIDIA GPU guest OS driver in the base image
  2. Install the XenServer Tools
  3. Install the latest version of Citrix HDX 3D Pro VDA

Erik Bohnhorst | Solution Architect – GRID
NVIDIA Corporation

Thanks everyone… I am good on the XenServer piece, as I followed all of the above instructions and that looks good. Thanks again! I think that my problem might be in the order of installation on the VM. Out of habit, I installed the tools first, THEN the NVIDIA drivers. I will uninstall everything and start over. Woo hoo! This stuff is fun! :-)

I solved my problem and it was self-inflicted. When I was setting up the hosts in XD 7.5, I accepted the default of "Passthrough" for the GPU configuration during the resource setup. When installing the VDA, I was selecting the K100 gpu. Once I deleted the host configuration and set it up properly, I was able to see the VM as a template for creating the catalog. It fails on the MCS creation process, but one thing at a time! :-)