Chrome windows get corrupted after resuming from suspend to RAM

Chrome windows always get corrupted after resuming from suspend to RAM. I can only fix Chrome by restarting it. See the following video:

nvidia-bug-report.log.gz (373.7 KB)

Any more information needed, feel free to ask me.

Hi laci1,
Would like to know if you have any logs or information pointing it to driver issue.
I can see any error in attached logs.

I can recreate issue on below configuration setup -

DELL Precision T7600 + Fedora release 32 + 5.6.6-300.fc32.x86_64 + Driver 440.100 + TITAN Xp + Chromium Ver 85 + 1 Display DELL U2415 with HDMI connection

I have filed a bug internally 200658266 for tracking purpose…

1 Like

I’m experiencing the same problem on Arch Linux, Chromium version 85.0.4183.102 (Official Build) Arch Linux (64-bit), Linux kernel version 5.8.8, nvidia drivers 450.66.

Adding this flags to ~/.config/chromium-flags.conf

--use-gl=desktop

… and / or these flags in chome://flags

#ignore-gpu-blacklist ENABLED
#enable-vulkan ENABLED

… seems to work around the issue for now.

Thank you for the quick feedback, everyone!

I set the suggested Chrome flags, and it seems to have resolved my issue. Thank you so much!

Just enabling Vulkan fixes it for me, no need for the other #ignore-gpu-blacklist nor the config change --use-gl=desktop flags

#enable-vulkan ENABLED

There is some concern about it being a viable solution long term though as it eats away at your RAM.

Either of these solutions seems to fix the issue, but use-gl=desktop causes video playback performance to take a nosedive to the point where youtube starts choosing 360p when set to auto.

The second solution (enable-vulkan) seems to work fine without any noticeable side effects.

Ok perhaps I spoke too soon. Seems like the vulkan flag also affects video playback performance.

Yes, the Vulkan flag degrades 4K 60 fps YouTube videos to about 5 fps, which is unbearable. I don’t consider this a viable workaround, unfortunately.

I have the same problem on a Tuxedo Laptop with Geforce GTX 1070 8GB RAM. The issue is quite annoying, help would be greatly appreciated.

Turns out the workarounds I mentioned are not very effective. I wasn’t using --use-gl=desktop and downgraded the nvidia driver from 450.66 to version 440.100 and after I resumed from suspend and the graphics are completely broken in Chromium, so I assume this could also be a problem in Chromium’s code.

Either way, performance is just terrible with this workaround. I only keep #ignore-gpu-blacklist active and it seems fine so far, but I suspect next resume from suspend will force me to restart Chromium again.

Edit: indeed, none of the workaround (except --use-gl=desktop) seem to fix the issue after resume from suspend, Chromium is totally borked. Time to switch to Firefox.

I’m also experiencing this problem on Arch Linux, XFCE, Google Chrome version 85.0.4183.102, nVidia GTX1060 drivers 450.66

Using vulkan seems to fix the corruption, but isn’t a viable solution because it kills video playback performance.

I downgraded to Chrome 84.0.4147.135, and all is good again. It’s the best workaround for the time being.

This same graphics corruption also happens after resume from sleep with Firefox when using WebRender hardware acceleration. The only way to fix the corruption is to restart Firefox.

My System

  • OS: KDE Neon 5.19 User Edition (Plasma Desktop 5.19.5, KDE Frameworks 5.74.0, Qt 5.15.0)
  • Linux Kernel: 5.4.68-xanmod1
  • Motherboard: ASRock X58 Extreme3 (Intel X58 chipset)
  • CPU: Intel Core i7-990x Bloomfield (3.46 GHz hexa-core, Socket 1366)
  • RAM: 12GB DDR3 PC3-10666 1333MHz
  • Video: EVGA NVIDIA GeForce GTX 980 Ti SC GAMING ACX 2.0+ w/ 6GB RAM
  • NVIDIA video driver: 450.66
  • Screen #1 (DVI-I-1, screen 0, marked as primary):
    • Monitor: ASUS VG248QE 24" LCD Monitor
    • Resolution: 1920 x 1280 @ 120 Hz
    • DPI: 91.79
  • Screen #2 (HDMI-0, screen 1):
    • Monitor: Dell P170Sb 17" LCD Monitor
    • Resolution: 1280 x 1024 @ 75 Hz
    • DPI: 96.42
  • X-Server: 11.0