CodeWorks for Android Error occurs during installation on Linux CENTOS


I have been trying to install Nvidia CodeWorks (CodeWorksforAndroid-1R6u1-linux-x64) for Android on Linux CENTOS 7 and the following error message shows up right after the directory configuration step:

Error occurs during installation.
Return Code: 2
exit status 127

I can’t fix it and I need to have it installed to be able to export Unreal Engine 4 Games to portable devices that use Android operational system.

Does anyone know how to fix it?


I have faced the similar issue while installing it on ubuntu. When i observed that prior to this error, it tried to install dos2linux. dos2linux installation might have failed. So i tried installing this dos2linux from the command line and then try to installed codework, with this the error was disappeared and it proceeded further.

However, i ran into other issue where the insatllation fails at Android Component Manager(after showing download manifest), the Component manager does not show any further things in the Window. Not sure of this issue. Couldn’t find out the reason for error. If anyone resolved this issue, suggestions on this could be helpful.