Installer won't launch for Codeworks for Android 1R4

I’m trying to install Codeworks for Android 1R4 on a Windows 10 machine.

When I run the executable, I get the Windows UAC popup asking if I want to let this program make changes to my computer, then when I click yes, nothing happens. The installation wizard never appears, and the program is not running according to task manager.

I have tried various things:

  • Making sure no Android/Visual Studio related applications are running and rebooting my machine
  • Disabling Windows Defender and Windows Firewall
  • Right-clicking on the exe and using Run As Administrator
  • Uninstalling all my existing TADP resources and deleting c:\NVPack
  • Running the Codeworks for Android 1R3 installer produces identical results.

I find that the older AndroidWorks 1R2 installer does launch successfully, and I’m currently attempting to install that, then hoping that’ll magically fix whatever has gone wrong with Codeworks 1R4, but it feels like a bit of a long shot (and also a long-winded process).

Anyone had similar problems and found a workaround?
Anyone got any ideas of what else I could try, or any way I can help narrow down the cause?

Hi User COlumbo,
First sorry for the inconvenience that has taken to you. Could you please provide the following information for us to investigate this issue?

  1. please send me the %temp% and %userprofile% on your computer.
  2. When you run the CodeWorks for Android 1R4 installer, pay attention to your %temp% folder and watch out whether tmp17176aaaaaa folder generated or not?
  3. If %temp%/tmp17176aaaaaa folder exists, open it and send me the file list under this folder.
  4. If %temp%/tmp17176aaaaaa folder is not empty, as a workaround you can copy the folder to C:\NVPACK, run the Launcher.exe to install CodeWorks for Android 1R4.

Amy Liu

Apologies for the delayed response. I had forgotten to follow this thread so wasn’t alerted to your reply.


(Where F is letters of my first name and S is letters of my surname).

Perhaps the space in my USERPROFILE is a red flag?

  1. A folder called tmp####aaaaaa is generated briefly and disappears almost immediately. The specific numbers seem to change each time I run, although there always seem to be 4 of them

3+4. The folder disappears too fast for me to check if there’s ever anything in there.