CodeWorks installation wizard is not starting

Hi guys, I’m trying to install CodeWorks and I had few issues. Here is what i did so far.

I didn’t have the folder called “Extras” in my “Engine” folder.
I downloaded all the versions from 1R4 to 1R6 from NVidia’s Website.
No matter how I try, The installation wizard does not appear. Nothing happens! I clicked on all of the versions but no other window appears. I don’t have problem with any other program being installed or uninstalled. I just installed Visual Basics with no problem.

I appreciate any help!

Hi Worldofcy,

Did you try CodeWorks 1R7?

I tried that as well, same issue. The permission window opens, i click “OK” and then nothing happens again.

Hi worldofcy,

Can you please provide more details on your host system?

I just came here as I have the same issue. Very strange but the installation is just not starting.

I downloaded CodeWorks-1R7-windows_b104.exe - Double click as per usual to install anything - say yes to the run as admin thing - nothing happens at all. And no program in task manager.

This is on windows 7

The previous version 1R6 does the same thing.

Do you need some other things installed before codeworks? It says RDP required?

I get the feeling the EXE is searching for something else before it can start…

Testing internally we are unable to replicate the issue and the dev team is traiging the issue. Will update the thread once there’s a fix/workaround.

Thanks For the reply.

Do you have any other suggestions about what I can try? This is a very strange issue that happends with all versions I’ve tried, 1r5 1r6 and 1r7 so far. Same problem.

  • Is there a way of getting a version of codeworks ‘unpacked’ or something so I can install without the wizard?

  • Is there other programs I can install which will do the same things as codeworks?

  • Could it be Something else I need to install? Does it check for Visual Studio 2017 or something (I have 15) Or do you know is the file trying to check form some prerequisite before opening?

Without this I’m unable to start Android development for UE4 so it’s quite urgent to find a solution!

Hi k3ddesign,

Can you please check if you have the right permissions to set environment variables?

If yes, then can you please check what the following env variables are set to when the installer is run:

NVPACK_ROOT                [<b>C:\NVPACK</b> (Default for 1R7)]
NVPACK_NDK_VERSION         [<b>android-ndk-r15c</b> (Default for 1R7)]
NVPACK_NDK_TOOL_VERSION    [<b>4.9</b> (Default for 1R7)]

Hi sdesai

How would I go about checking those bits?

Hi k3ddesign,

You can check the user environment variables in system settings. You can follow the below steps:

For Windows 10
In Search, search for and then select: System (Control Panel)
Click the Advanced system settings link.
Click Environment Variables.

For Windows 7
From the desktop, right click the Computer icon.
Choose Properties from the context menu.
Click the Advanced system settings link.
Click Environment Variables.

You can find the entries under User Variables.

The issue seems to be a corner case scenario and has not been able to reproduce internally. The issue is being triaged with priority.

Hi k3ddesign, worldofcy, and others experienced this problem:

  1. Can you please check what permissions you have on this folder?
    C:\Users\dongbox\AppData\Local\Temp

  2. After “Double click as per usual to install anything - say yes to the run as admin thing”, can you please check inside C:\Users\dongbox\AppData\Local\Temp folder,if you can find any folder named “tmp#####aaaaaa”? (#s represents some numbers) If you can, can you please check whats inside that folder?

Thanks!

Hi All!

I’ve checked all those things.

dongbox - the temp folder has full permissions. In the temp folder I can’t find a folder named “tmp#####aaaaaa”- I can find lots of FILES like that though - tmp6696aaaaaa and such.

Sdesai - I’ve looked in the environment variables. The top use variables section has:

PATH %CommonProgramFiles%\Microsoft Shared\Windows Live;C:\Users\K3D-3D DESIGN\AppData\Roaming\npm
TEMP %USERPROFILE%\AppData\Local\Temp
TMp %USERPROFILE%\AppData\Local\Temp

The bottom System Variables bit has to many lines to copy and paste here but the 3 lines you told me to look for don’t exist there. Should the below 3 lines be in there somewhere? And if so should I add them in manually?

NVPACK_ROOT [C:\NVPACK (Default for 1R7)]
NVPACK_NDK_VERSION [android-ndk-r15c (Default for 1R7)]
NVPACK_NDK_TOOL_VERSION [4.9 (Default for 1R7)]

Hi k3ddesign,
Can you open the folder and see whats inside? A screenshot would be helpful.
Thanks.

These forums don’t have an attach image function which is a bit annoying.

They are all files not folders. If i open the files with notepad there’s a whole load of text though. You want to see that.

I do have lots of folder with names like ‘tmpgasnpk’ - Inside those is a folder ‘gen_py’ and inside that an init.py and dicts.dat file.

Again no folder with ‘aaaaaa’ after it. Only files.
2.jpg
1.jpg

2.jpg

1.jpg

Hello,

@k3ddesign please see this link regarding attachments.

https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

For attaching images, click on the located in the text editor.

Best,
Tom

CHeers!

Thanks k3ddsign. It’s really helpful.
We just had a new release for codeworks today, can you download the latest version to see if it solved your problem? If not, please let me know. I’ll give you a workaround.
https://developer.nvidia.com/gameworksdownload#?dn=codeworks-for-android-1r7

NVPACK_NDK_VERSION [android-ndk-r15c (Default for 1R7)]

Thanks but unfortunately the exact same thing!

It appears briefly in Task Manager / Processes and then disappears instantly and won’t start.

Work around it is!!!???