Computer boot loops when Nvidia Tesla P100 is installed

Apologies if this is the incorrect place to post this.

This is probably a pretty obscure issue but I’m having trouble getting my Dell Precision 5820 to post when a have a Tesla P100 in either of the x16 capable PCIe slots (Slot2 and Slot4). It just boot loops forever.

I do have “Memory Map IO above 4GB” enabled within the BIOS and have tried disabling CSM but still no luck.

The P100 does work in my X570 desktop with no issue so I don’t believe there is an issue with the card.

I’m using a separate power supply for the P100 to the Dell while I wait for a PCIe-EPS power adapter (The P100 uses 8-pin EPS instead of PCIe but the Dell only has spare PCIe connectors) although I don’t see why this would be an issue and this also works in my desktop.

I’m aware that the Tesla P100 is a server card and also requires external cooling but I have a solution for that.

The Dell currently has a Xeon W-2145 and 4x32GB 2400MHz DDR4.

Thanks in advance for any assistance!

Tesla P100 is not qualified in any of the platforms you mentioned. It’s not intended for use in any of those platforms. It is a server card and requires server monitoring/management with cooling. It also requires a proper system BIOS that knows how to map the necessary resources for the card. Yes, I am aware you are aware of that, however these forum threads will often be read by other people. Not all of my comments are strictly intended for you personally.

Assuming the OS is linux, the boot loop may also be due to a NVIDIA driver installation that installed the OpenGL libraries. If the primary display adapter is not a NVIDIA GPU in that case, the non-NVIDIA display driver stack can get corrupted, resulting in a boot loop. There are various forum articles about this that you can find with a bit of searching, that have instructions for how to prevent the install of components that will corrupt a non-nvidia display driver stack. Here is an example. Furthermore, the linux install guide has instructions.