Configuration of dual monitors on openSuSE 13.1

My dual monitor setup is not behaving as in the past and setup was rocky.

Is TwinView available for openSuSE 13.1? The nVidia gui does not allow me to select this option. xorg.conf is showing only nvidiaXineramaInfoOrder.

monitors: identical NEC 1600x1200
processor: GTS 450
linux kernel:- 3.11.10-7.1
driver package:
nvidia-gfxG03-kmp-desktop 331.49_k3.11 6_4-29.1
x11-video-nvidiaG03 331.49-29.1
xorg-x11-driver-video-nouveau 1.0.9-3.1.2

All advice welcome. Thanks.

My xorg.conf is as follows:

nvidia-settings: X configuration file generated by nvidia-settings

nvidia-settings: version 331.49 (buildmeister@swio-display-x86-rhel47-10) Wed Feb 12 20:59:53 PST 2014

nvidia-xconfig: X configuration file generated by nvidia-xconfig

nvidia-xconfig: version 331.49 (buildmeister@swio-display-x86-rhel47-10) Wed Feb 12 21:00:07 PST 2014

Section “ServerLayout”
Identifier “Layout0”
Screen 0 “Screen0” 0 0
Screen 1 “Screen1” RightOf “Screen0”
InputDevice “Keyboard0” “CoreKeyboard”
InputDevice “Mouse0” “CorePointer”
Option “Xinerama” “0”
EndSection

Section “Files”
EndSection

Section “InputDevice”

# generated from data in "/etc/sysconfig/mouse"
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "IMPS/2"
Option         "Device" "/dev/input/mice"
Option         "Emulate3Buttons" "yes"
Option         "ZAxisMapping" "4 5"

EndSection

Section “InputDevice”

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Unknown”
ModelName “NEC LCD2190UXi”
HorizSync 31.0 - 92.0
VertRefresh 50.0 - 85.0
Option “DPMS”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “Unknown”
ModelName “NEC LCD2190UXi”
HorizSync 31.0 - 92.0
VertRefresh 50.0 - 85.0
EndSection

Section “Device”
Identifier “Device0”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTS 450”
BusID “PCI:7:0:0”
Screen 0
EndSection

Section “Device”
Identifier “Device1”
Driver “nvidia”
VendorName “NVIDIA Corporation”
BoardName “GeForce GTS 450”
BusID “PCI:7:0:0”
Screen 1
EndSection

Section “Screen”

Removed Option “metamodes” “DVI-I-2: nvidia-auto-select +0+0, DVI-I-3: nvidia-auto-select +1600+0”

Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-0"
Option         "metamodes" "DVI-I-2: nvidia-auto-select +0+0"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection

EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
Option “Stereo” “0”
Option “metamodes” “DVI-I-3: nvidia-auto-select +0+0”
Option “SLI” “Off”
Option “MultiGPU” “Off”
Option “BaseMosaic” “off”
SubSection “Display”
Depth 24
EndSubSection
EndSection

i also use openSUSE 13.1 with dual screen, but i use a very simple xorg configuration.

  1. i don't use an xorg.conf
  2. i use mostly the default .conf files located in /etc/X11/xorg.conf.d
  3. i don't use a 50-device.conf, 50-monitor.conf, 50-screen.conf
  4. BUT i DO use a 15-nvidia.conf

here is my 15-nvidia.conf:

Section "Device"
  BoardName    "GeForce GTX 765M"
  Driver       "nvidia"
  Identifier   "Device[0]"
  Option       "Coolbits" "13"
  Option       "ProbeAllGpus" "false"
  Option        "MultisampleCompatibility" "true"  # use of separate front and back multisample buffers
  Option        "GLShaderDiskCache" "true"
  Option        "IncludeImplicitMetaModes" "Scaling=Centered, Derive16x9Mode=false"
  Option        "AllowUnofficialGLXProtocol" "true"
  Option         "SoftwareRenderCacheSize" "8388608"

# TV
  Option       "TVStandard" "HD1080p"

  # nvidia dual head
  Option       "TwinView" "1"
  Option       "TwinViewXineramaInfoOrder" "DFP-0, DFP-2"
  Option       "Metamodes" "DFP-0: 1920x1080+0+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }, DFP-2: nvidia-auto-select+1920+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }; DFP-0: 1600x900+0+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }, DFP-2: nvidia-auto-select+1600+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }; DFP-0: 1280x720+0+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }, DFP-2: nvidia-auto-select+1280+0 { ForceFullCompositionPipeline=On,Scaling=Centered,Derive16x9Mode=false }"
  Option       "MetaModeOrientation" "DFP-0 LeftOf DFP-2"
  VendorName   "NVidia"
EndSection

Section "ServerFlags"
Option "IgnoreABI" "True"
EndSection

Thanks for the reply. I have two questions:

  1. Am I correct that you are not using the nVidia driver(s) from the nVidia repository? If not, perhaps I should uninstall mine. I do recall that I had some functionality after the original installation before downloading the nVidida drivers.

  2. How was your 15-nvidia.conf file generated? Manually coded? I have studied the nVidia readme http://it.download.nvidia.com/XFree86/Linux-x86/319.17/README/index.html, but have not found enough to help me code the file(s). Further, where is the 15-nvidia.conf file stored? /etc/x/11 or etc/x11/xorg.conf.d?

Thank you again for your help.

i use the latest driver from nvidia. links to it are here: https://devtalk.nvidia.com/default/topic/533434/linux/current-graphics-driver-releases/

but i think it doesn’t matter if you use the latest driver or an older version.
i prefer installing it manually. so i can always use the latest driver. of course, i have to reinstall everytime i update the kernel and/or XOrg.

it was derived from my old xorg.conf. in the past i also used an xorg.conf, and the 15-nvidia.conf is nothing else than the device-section of the old xorg.conf.

it is not complicated to generate the 15-nvidia.conf.
it is simple a device section.
and you can place all commands referenced in the nvidia documentation for the nvidia device section.
if would start with this:

Section "Device"
BoardName "GeForce GTS 450"
Driver "nvidia"
Identifier "Device[0]"
# nvidia dual head
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DVI-I-2, DVI-I-3"
Option "MetaModeOrientation" "DVI-I-2 LeftOf DVI-I-3"
VendorName "NVidia"
EndSection

you could also try a dedicated metamode-line:

Option "Metamodes" "DVI-I-2: 1600x1200+0+0 , DFP-2: 1600x1200+1600+0"

and instead of using 1600x1200 you also could try nvidia-auto-select.

it has to be stored in /etc/X11/xorg.conf.d.
like all other XOrg conf files are.

you are welcome.

Thank you. I need to study your reply carefully.

It is a very interesting topic as i am having the same case.
i am using the overman79 approach and trying to make it able to use HDMI, but no luck so far.
my question is, where did you get the information of 15-nvidia.conf from?

the output of hwinfo --gfxcard is as followed:
10: PCI 02.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: _Znp.4zwOdn684xF
SysFS ID: /devices/pci0000:00/0000:00:02.0
SysFS BusID: 0000:00:02.0
Hardware Class: graphics card
Model: “Intel VGA compatible controller”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x0166
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x2103
Revision: 0x09
Driver: “i915”
Driver Modules: “drm”
Memory Range: 0xf7400000-0xf77fffff (rw,non-prefetchable)
Memory Range: 0xd0000000-0xdfffffff (ro,non-prefetchable)
I/O Ports: 0xf000-0xf03f (rw)
IRQ: 43 (56128 events)
Module Alias: “pci:v00008086d00000166sv00001043sd00002103bc03sc00i00”
Driver Info #0:
Driver Status: i915 is active
Driver Activation Cmd: “modprobe i915”
Config Status: cfg=no, avail=yes, need=no, active=unknown

22: PCI 100.0: 0300 VGA compatible controller (VGA)
[Created at pci.319]
Unique ID: VCu0.hRhxAYgUv16
Parent ID: vSkL.rPVqNC3_nn6
SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
SysFS BusID: 0000:01:00.0
Hardware Class: graphics card
Model: “nVidia VGA compatible controller”
Vendor: pci 0x10de “nVidia Corporation”
Device: pci 0x0fd1
SubVendor: pci 0x1043 “ASUSTeK Computer Inc.”
SubDevice: pci 0x2103
Revision: 0xff
Memory Range: 0xf6000000-0xf6ffffff (rw,non-prefetchable)
Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
Memory Range: 0xf0000000-0xf1ffffff (ro,non-prefetchable)
I/O Ports: 0xe000-0xefff (rw)
Memory Range: 0xf7000000-0xf707ffff (ro,non-prefetchable)
IRQ: 16 (299 events)
Module Alias: “pci:v000010DEd00000FD1sv00001043sd00002103bc03sc00i00”
Driver Info #0:
Driver Status: nvidiafb is not active
Driver Activation Cmd: “modprobe nvidiafb”
Driver Info #1:
Driver Status: nouveau is not active
Driver Activation Cmd: “modprobe nouveau”
Driver Info #2:
Driver Status: nvidia is not active
Driver Activation Cmd: “modprobe nvidia”
Config Status: cfg=new, avail=yes, need=no, active=unknown
Attached to: #9 (PCI bridge)

Primary display adapter: #10

the only way i can use my nvidia is by using optirun or primusrun

any clue for me?

from the nvidia documentation. section “X config options”.
http://us.download.nvidia.com/XFree86/Linux-x86_64/337.12/README/xconfigoptions.html

i am afraid no.
it seems you are using a notebook with nvidia optimus.
this is not very well supported under linux. :-(
i myself carefully searched for a notebook which DOES NOT use/contain nvidia optimus.

Sigh… i wished i knew it 6 month ago… :(
anyway… i’ve tried linux mint live CD… and it can use the HDMI. I dont think the live cd uses nvidia driver as i cant see any trace of nvidia in it.

does it means i still have a hope? pray hard :)
how can you tell that this NB use the optimus ? hmm… this is asus n56vz…

-all the best-

yes, selecting a new notebook for running under linux takes some time and research…
it took me quite some time to find the ASUS G750J… ;-)

most likely it uses the intel-gfx-chip, and mot likely the intel chip also has access to the HDMI output.
you can check this when analyzing the /var/log/Xorg.0.log and /etc/X11/xorg.conf (or /etc/X11/xorg.conf.d) files when booted with the live-cd.

if the live-cd is able to use HDMI, then you installed linux can do this also.

i interpreted this from the output of your “hwinfo --gfxcard” command.
there are 2 “Hardware Class: graphics card” entries.
and these links prove me right:
http://www.notebookcheck.net/Review-Asus-N56VZ-S4044V-Notebook.78305.0.html
https://forums.geforce.com/default/topic/522057/geforce-mobile-gpus/question-about-optimus/
http://forum.notebookreview.com/asus/664468-asus-n56vz-ds71-first-impressions-15.html

Ironically, much of the functionality appears to be available with the stock SuSE 13.1 install, without the nVidia driver installed. That is, I have one large continuous screen and can move items back and forth between the two monitors or have a window straddle the two displays.

I first configured dual monitors 10 years ago with 9.1 and then with successive releases, each time using the nVidia driver. I don’t understand what the nVidia driver will now provide over the current configuration in 13.1.

Although I installed the driver manually under 11.4, I note that openSuSE has a “one-click” option, as well as installation via Yast and Zypper. Do these work? Is one preferable over the others?

i’ve tried the “once click” and the “hard way”… none of them works for me…
then i follow the instructions from http://smithfarm-thebrain.blogspot.cz/2013/10/opensuse-131-nvidia-optimus-bumblebee.html it works… the only thing left… i just want to have the HDMI running and hopefully it runs by using the nvidia card.

i dont think i will give up on it yet… there are some infos from ubuntu users that can make it so…
pls refer to http://www.webupd8.org/2012/08/get-hdmi-working-with-nvidia-optimus-on.html

will i switch to ubuntu? i dont think so… i’ve been using suse since version 4 (before suse i tried red had, slackware and debian) and so far i have not found any distro that has a tool like yast.

anyway, i’ve no problem for dual monitors by using the vga port. and i can even use the hdmi (via intel card) if i willing to use linux mint.

hehehe… i think… i just too old to adopt other distros approach… so… i will fight this case as for my weekend case :)

this is what i did :

  1. chk if the HDMI output is wired to nvidia :
    optirun nvidia-xconfig --query-gpu-info

the result when a tv connected to hdmi port will be different to if not conected. what does it means to me? i think… the HDMI is wired to nvidia

  1. create the xorg.conf :
    optirun nvidia-xconfig --enable-all-gpus
    it will create the /etc/X11/xorg.conf

i edited it and add the BusID which i got from the result of number 1
i then renamed to xorg.conf.try (just to avoid any problem if i have to restart my notebook

  1. test the Xorg config :
    startx – -config org.conf.nvidia

voila… the output goes to the tv via hdmi … but… my notebook’s monitor goes dark and unusable…

hmmm… it was a good fight… i’ll continue fighting a bit more :)

i hope it will give a bit light to anyone in the same problem … have fun guys…

pff… sorry typo… on step 3
startx – -config org.conf.nvidia it should be startx – -config org.conf.try

oh no… i think i miss 1 step… i can not replicate the small victory again… :( aaaarrrrgggghhhh

stupid me… it should be :
optirun startx – -config org.conf.try

thx god… now… the fight can be continued :)

all the best guys…

There were responses to my initial query by Mad Penguin - and now they have disappeared!

I was going to inquire and will now ask why the 32-bit nVidia driver doesn’t work on my machine. nVidia states that I am running a 64-bit configuration, and hardware info in Yast confirms that. But I installed the 32-bit version of openSuSE 13.1.

that is y i wonder… where the mad penguin gone? not only that… all of his posting also gone…
i wonder… y did install the 32 bit version while your HW is capable to use the 64 bit? is there any special reason?

On windows, I have 32-bit applications, so I have generally stayed with 32-bit OSs across all platforms. Also, I am about to launch a virtual machine on one of the pcs (host will be suse 13.1, guest will Windows XP). Since I will be running 32-bit applications on the virtual machine, I have decided stay with 32-bit.

As to the nVidia driver, it is not clear what it will buy me over my existing configuration. Under the principle of if it isn’t broken, I may not fix it for now. But I’m willing to be persuaded that I would benefit with an nVidia driver.

w2tq, i am using opensuse 13.1 64 bit on my asus 56vz and i am able to run most of linux 32 bit apps and some windows 32 bit apps…

i am using the word “most of” and “some” is because… i cant and will never try all apps in the world :)

most of the case… all what i need is to install the 32bit libs on my opensuse.

my suggestion… if you have an old 64 bit machine … pls use it to try 64 bit version and try to run the 32 bit app of yours…

have fun…