Configuring Huawei e3372 4G/LTE dongle on jetson nano

Hi i have been trying to use moblie broadband by using data card with a huawei 4g dongle. The data card is totally working (singtel hi card)
the dongle i m using is huawei e3372 4g/lte
Thanks in advances for the all helps!

Setting up the 4G/LTE dongle

On the Jetson Nano, setting up the dongle will be a tedious process as the kernels themselves do not come with the driver(huawei_cdc_ncm) included. To do this, we have to build our own kernel.

Steps to configure the dongle:

Firstly, clone the BuildKernelAndModules in the Jetsonhacks Nano repository in github, https://github.com/JetsonHacksNano/buildKernelAndModules

git clone https://github.com/JetsonHacksNano/buildKernelAndModules

Open the folder where it is downloaded, it should be in your home directory.

Once you located your buildKernelAndModules folder, run the following codes

  1. ./getKernelSources.sh
  2. ./makeKernel.sh
  3. ./makeModules.sh
  4. ./copyImage.sh

These steps will take awhile(especially the makeKernel and makeModules scripts)

Once everything is downloaded, run the ./editConfig.sh

In the config settings,

Enable these following settings :

Device Drivers —>

Network device support —>

PPP (point-to-point protocol) support – PPP

[M] PPP BSD-Compress compression – PPP_BSDCOMP

[M] PPP Deflate compression – PPP_DEFLATE

[M] PPP MPPE compression (encryption) – PPP_MPPE

[M] PPP over Ethernet - PPPOE

PPP support for async serial ports – PPP_ASYNC

[M] PPP support for sync tty ports – PPP_SYNC_TTY

USB support —>

<*> USB Serial Converter support —>

USB Serial Console device support – USB_SERIAL_CONSOLE

USB Generic Serial Driver – USB_SERIAL_GENERIC

USB driver for GSM and CDMA modems – USB_SERIAL_OPTION

The * means it is built as a kernel, the M denotes it is built as a Module.

To enable these in the config file, type ‘y’ to enable it as a kernel, ‘m’ to enable it as a module.

Once this is done, save and exit the file.

Run ./makeKernel.sh and ./makeModules.sh to build the new kernels.

Run ./copyImage.sh to copy the image to the boot folder.

Reboot the jetson by:

Sudo reboot now

You should have successfully enabled the 4G huawei dongle! However, it will still not work as you still have not configured the APN for the dongle.

Ctrl+alt+t to open a new Terminal.

Install ModemManager and NetworkManager by running these 2 codes :

sudo apt-get install modemmanager

sudo apt-get install network-manager

Run lsusb to check if the dongle is connected

You should see this : 12d1:1506 Huawei Technologies

Once you confirmed that the dongle is connected, run mmcli -L to see if it is detected as a modem.If they mentioned “modemmanager process in the bus unavailable”, you have to enable ModemManager as a service and start it on boot:

sudo systemctl enable ModemManager

sudo systemctl start ModemManager

Run mmcli -L again and you should have detected a modem with a number at the end.

Run mmcli -L x (replace x with the number of the modem)

This will show you the full modem settings.

Check whether the dongle is configured and to confirm whether the device is

detected:

nmcli d

Next type this in the Terminal :

nmcli c add type gsm ifname ttyUSB0 con-name sandbox_lte apn

sandbox.singtel.com ipv4.dns “8.8.8.8,8.8.4.4”

Sandbox_lte is the connection name, it can be anything you set it to be.

sandbox.singtel.com is the APN and it has to be exactly the same.

Type these into the Terminal:

nmcli c edit sandbox_lte

goto ipv4

set dns 8.8.8.8, 8.8.4.4

verify

save

Activate

However, we failed at the last step, the connection activation was not successful


Alternatively i also tried to created a connection through GUI

First we insert the dongle and then create a connection type

Chose mobile broadband

CHOSE SINGAPORE

CHOSE SINGTEL AS DATA PROVIDER

We chose ideas MMs and the apn was automatically set as e-ideas

This is the setting when we finished

Able to detect the modem Huawei technologyies co,.ltd modem/networkcard

There is connection, however, it was forever connecting

When I use the command prompt to check its state, it was displayed as getting Ip configuration

But forever stuck there.