Unable to create a hotspot with Nvidia Jetson Nano and usb dongles

Hello, I have used both the Nvidia Jetson Nano from the developer kit (4GB of RAM) with Jetson Linux version 32.6.1 and this jetson nano carrier with the newest Jetson Linux 32.7.1, while trying to set up the board as a AP hotspot.

Initially I did it using the Intel M2 wifi module in the dev kit carrier version, no issues whatsoever, but since the avermedia model does not have this port available I thought about using a USB dongle to set up the AP. I have been unsuccessfull in doing so, see the error message attached below (point 8).

I followed the same exact process with the Intel module and the USB dongles (tp link dongle and this other dongle), which is attached in the following images:

  1. Check if the nano does detect the usb dongle drivers, in both it did without having to manually download any drivers:

  2. Check the output of iw list, which printed nothing, I think is strange since I’m capable of connecting to wireless networks without issues.

  3. Go to the network manager and automatically create a new hostpot using the default available wlan.

  4. Wireless hotspot successfully created? I question marked this since at this point the hotspot wasn’t available.

  5. Delete this hotspot and manually create it from the network connections

  6. Configure the new hotspot’s SSID password, wlan, inet settings…

  7. Try to connect to configured hotspot generated in the hidden networks menu.

  8. Error message that appears.

I tested by manually configuring the AP using hostapd and it didn’t work as well, by the way I tried to replicate the hostapd script configuration in a raspberry Pi model 3 without wifi and the board generated the hotspot out of the box.

My guess is that this issue has to do with the kernel of the Linux tegra OS or something about the wifi configuration? Any ideas regarding how can I make it work/bypass it?

Thank you for your time and I’m awaiting your response.

1 Like

Hello, I’m still waiting for a reply in this topic.

I have tested the same procedure yet again with another usb dongle from the same brand than the one in the original post, in this case without the antenna and the result was still the same.

Hello!? We need an answer, can’t delay more the project.


It looks like you posted this in the wrong category. I am moving this to the Jetson Nano forum so support has visibility.

Tom K


Could you follow the instructions here to create an AP?

Hello @alanz, first of all thank you for the response.

In the thread you posted below I tried to reproduce the steps listed as a solution by the user @karunakar.r, but what surprised me was the fact that in this part of the thread Jetsonnano with wifi AP - #8 by karunakar.r , said user mentioned that he was going to use the Intel AC8265 nic module for jetson nano, and the part of the post marked as a solution mentioned that he was able to create the AP through this board, not a USB. As I said in the first message of this post, I could already achieve this as well, and using the integrated GUI tool for networks, but in the new board I’m working with I don’t have an M2 slot available.

Furthermore, just in case I tried the commands mentioned in the post and the output I got was the following:
dmesg_errors.log (2.2 KB)
output.log (3.5 KB)

USB dongles that I am using:
TP link
another dongle used

Thanks for provide the feedback on this. I don’t have a chance to try with USB dongles.

Does the dmesg log captured after those insturctions?

Have you ever sucessed to setup the AP on X86 host?

The dmesg log was captured after the instructions yes.
Have you ever sucessed to setup the AP on X86 host? Not in an X86, haven’t tried it there, but I successfully set up the AP on a raspbery pi model 3 with the same USB dongle.