Jetsonnano with wifi AP


I recently bough TP-LINK (TL-WN725N), 150 MBPS WIRELESS N NANO USB ADAPTER for wifi connectivity for Nano. I want to use the same for creating hotspot as well. I tried with create_AP as well using GUI option of creating hotspot. None sofar worked. Could someone please help here.

I also had tried options mentioned in below ticket


Is the station mode working?
Are you sure this adapter supports AP mode? What kind of error log in dmesg did you see after you try to create AP by GUI?

Hi @WayneWWW Thanks for response.
I dont see any error message while creating hotspot through GUI. But, upon creation, I am not able to see the newly created hotspot in wifi network from my laptop or from my mobile device. I even have tested by turning off other wifi networks while creating hotspot network

As per info from internet, it supports AP mode

With what method that you give out a conclusion that there is no error log?

I mean do you really know where to check the log?

Sorry @WayneWWW for confusion. Please find below log message once I create hotspot
dmesg --level=emerg,alert,crit,err,warn

[ 0.450952] tegra-pmc 7000e400.pmc **: i2c-thermtrip node not found, emergency thermal reset disabled.**

[ 1.120890] tegradc tegradc.0 **: hdmi: BL set VIC 0**

[ 1.121956] tegra-i2c 7000c700.i2c **: no acknowledge from address 0x50**

[ 1.125310] tegradc tegradc.1: dpd enable lookup fail:-19

[ 1.132804] **edid invalid**

[ 1.179602] **edid invalid**

[ 1.236457] **edid invalid**

[ 1.312449] tegra-vii2c 546c0000.i2c **: no acknowledge from address 0x22**

[ 1.312535] pca953x 8-0022: failed reading register

[ 1.317494] pca953x **: probe of 8-0022 failed with error -121**

[ 1.375526] tegradc tegradc.0: hdmi: edid read failed

[ 1.549261] Root device found **: mmcblk0p1**

[ 1.754342] Found dev node **: /dev/mmcblk0p1**

[ 1.791769] **Rootfs mounted over mmcblk0p1**

[ 1.814582] **Switching from initrd to actual rootfs**

[ 1.914728] usb 1-2.4 **: Device not responding to setup address.**

[ 2.087640] cgroup: cgroup2: unknown option "nsdelegate"

[ 2.122706] usb 1-2.4 **: Device not responding to setup address.**

[ 2.282424] systemd[1] **: File /lib/systemd/system/systemd-journald.service:36 configures an IP firewall (IPAddressDeny=any), but the local system does not support BPF/cgroup based firewalling.**

[ 2.282433] systemd[1] **: Proceeding WITHOUT firewalling in effect! (This warning is only shown for the first loaded unit using IP firewalling.)**

[ 2.334061] usb 1-2.4: device not accepting address 4, error -71

[ 2.429474] **r8168 Copyright (C) 2017 Realtek NIC software team <>**

**This program comes with ABSOLUTELY NO WARRANTY; for details, please see <>.**

**This is free software, and you are welcome to redistribute it under certain conditions; see <>.**

[ 3.940080] ar0234 **: loading out-of-tree module taints kernel.**

[ 3.942011] **RESET = 1e1**

[ 3.942305] **BOOT = 1e2**

[ 3.942314] **cam_probe...clk:1200**

[ 4.108692] **Current Firmware Version - (1124CUNXXXXXX01110f824bf8XXXXXXX)**

[ 5.028249] **using random self ethernet address**

[ 5.028251] **using random host ethernet address**

[ 5.934628] r8188eu **: module is from the staging directory, the quality is unknown, you have been warned.**

[ 6.120721] **using random self ethernet address**

[ 6.134092] **using random host ethernet address**

[ 11.948180] ar0234 7-0042: ISP Already Initialized !!

[ 12.087105] ar0234 8-0042: Unable to toggle RESET GPIO

[ 12.092410] ar0234 **: probe of 8-0042 failed with error -22**

Please also consult with the vendor and see what kind of firmware/driver setting they need to make this product run in AP mode.

Sure @WayneWWW I already reached them, and waiting for their response.

I also have Intel AC8265 WIRELESS NIC FOR JETSON NANO, WIFI / BLUETOOTH. Do you think its possible to set AC with this wifi element

I tried with below command, and is working in Intel 8265 module, the same didn’t work in T-link

nmcli con add type wifi ifname wlan0 mode ap con-name WIFI_AP ssid DL_AP

nmcli con modify WIFI_AP bg

nmcli con modify WIFI_AP 1

nmcli con modify WIFI_AP 802-11-wireless-security.key-mgmt wpa-psk

nmcli con modify WIFI_AP 802-11-wireless-security.psk 11223344

nmcli con modify WIFI_AP ipv4.method shared

nmcli con up WIFI_AP