No WiFi on Jetson Nano

I am trying to use a Jetson Nano 4GB module to power a drone. For this application i need the Jetson Nano to be able to connect to Wi-Fi. This, however, seems to be quite a task to get working.
For starters i have consulted with the following page with a list of supported WiFi modules:

And bought myself a Linksys WUSB6300v2 dongle. Since this didn’t work out of the box I went ahead and found some driver installation guides here on the forum, and i have tried the following driver github repos:

None of these worked.

It should be stated as well that i am using the Jetson Nano compute module in a Xavier NX carrier board (as the dev kits are completely impossible to get by and i had the Xavier board lying around) but even though this board comes with a WiFi m.2 module, this doesn’t work either.

I also tried several other USB-WiFi dongles:
Asus USB-AC54 (with rtl8812BU chipset)
Sandberg Micro WiFi USB Dongle (rtl8811CU)

Absolutely nothing works, and having spent more than 10 hours on WiFi problems has not been a fun experience, please help.

I’m not sure what else to include to help you with troubleshooting, but here is a dmesg output:

1.txt (62.3 KB)

Linksys WUSB6300 is confirmed to be working since r32.4, no need for extra driver, not sure about the difference between Linksys WUSB6300V2 and Linksys WUSB6300.

As a quick try I would suggest another wifi module list in our SCL. eg: Intel 8265NGW, TP-Link TL-WN722N, Linksys WUSB6300.

I went and bought myself a TP-Link TL-WN722N, and it worked!
Perhaps only the “v1” version of Linksys WUSB6300 is actually supported…

I was unable to find any information about the differences, but v2 might make use of a different chipset.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.